Displaying 8 results from an estimated 8 matches for "__vfree".
Did you mean:
__cfree
2020 Jun 17
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...; Not just performance critical, but correctness critical. Since kvfree()
> may allocate from the vmalloc allocator, I really think that kvfree()
> should assert that it's !in_atomic(). Otherwise we can get into trouble
> if we end up calling vfree() and have to take the mutex.
FWIW __vfree already checks for atomic context and put the work into a
deferred context. So this should be safe. It should be used as a last
resort, though.
--
Michal Hocko
SUSE Labs
2020 Jun 17
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...; Not just performance critical, but correctness critical. Since kvfree()
> may allocate from the vmalloc allocator, I really think that kvfree()
> should assert that it's !in_atomic(). Otherwise we can get into trouble
> if we end up calling vfree() and have to take the mutex.
FWIW __vfree already checks for atomic context and put the work into a
deferred context. So this should be safe. It should be used as a last
resort, though.
--
Michal Hocko
SUSE Labs
2020 Jun 17
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...ritical. Since kvfree()
> > > may allocate from the vmalloc allocator, I really think that kvfree()
> > > should assert that it's !in_atomic(). Otherwise we can get into trouble
> > > if we end up calling vfree() and have to take the mutex.
> >
> > FWIW __vfree already checks for atomic context and put the work into a
> > deferred context. So this should be safe. It should be used as a last
> > resort, though.
>
> Actually, it only checks for in_interrupt().
You are right. I have misremembered. You have made me look (thanks) ...
>...
2020 Jun 17
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...ritical. Since kvfree()
> > > may allocate from the vmalloc allocator, I really think that kvfree()
> > > should assert that it's !in_atomic(). Otherwise we can get into trouble
> > > if we end up calling vfree() and have to take the mutex.
> >
> > FWIW __vfree already checks for atomic context and put the work into a
> > deferred context. So this should be safe. It should be used as a last
> > resort, though.
>
> Actually, it only checks for in_interrupt().
You are right. I have misremembered. You have made me look (thanks) ...
>...
2020 Jun 17
0
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...itical, but correctness critical. Since kvfree()
> > may allocate from the vmalloc allocator, I really think that kvfree()
> > should assert that it's !in_atomic(). Otherwise we can get into trouble
> > if we end up calling vfree() and have to take the mutex.
>
> FWIW __vfree already checks for atomic context and put the work into a
> deferred context. So this should be safe. It should be used as a last
> resort, though.
Actually, it only checks for in_interrupt(). If you call vfree() under
a spinlock, you're in trouble. in_atomic() only knows if we hold a...
2020 Jun 17
0
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
...7PM +0200, Michal Hocko wrote:
> On Wed 17-06-20 04:08:20, Matthew Wilcox wrote:
> > If you call vfree() under
> > a spinlock, you're in trouble. in_atomic() only knows if we hold a
> > spinlock for CONFIG_PREEMPT, so it's not safe to check for in_atomic()
> > in __vfree(). So we need the warning in order that preempt people can
> > tell those without that there is a bug here.
>
> ... Unless I am missing something in_interrupt depends on preempt_count() as
> well so neither of the two is reliable without PREEMPT_COUNT configured.
preempt_count() a...
2020 Jun 16
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote:
> On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote:
> > v4:
> > - Break out the memzero_explicit() change as suggested by Dan Carpenter
> > so that it can be backported to stable.
> > - Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
> > now as there can be a
2020 Jun 16
2
[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote:
> On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote:
> > v4:
> > - Break out the memzero_explicit() change as suggested by Dan Carpenter
> > so that it can be backported to stable.
> > - Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
> > now as there can be a