Displaying 3 results from an estimated 3 matches for "1statvfs64".
Did you mean:
statvfs64
2009 Dec 07
1
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
...ic number to a 'static const char' is
> fine with me, please don't use a macro though.
I do not like macros either. However, how should I remove magic
numbers from
| } else if (Name == "\1stat64" ||
| Name == "\1lstat64" ||
| Name == "\1statvfs64" ||
| Name == "\1__isoc99_sscanf") {
without using a macro? Something like
| } else if (Name[0] == llvm_asm_prefix && Name.slice(1, 0) == "stat64" ||
| Name[0] == llvm_asm_prefix && Name.slice(1, 0) == "lstat64" ||
|...
2009 Nov 26
0
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
On Nov 18, 2009, at 10:17 AM, Timo Juhani Lindfors wrote:
> Hi,
>
> llvm, clang and llvm-gcc contain numerous references to 1, '\1',
> '\01', '\001', "\01" and "\01foo". This makes it difficult for one to
> find all occurences of this prefix character and lacks a central place
> where the prefix could be documented. (See for example
2009 Nov 18
2
[LLVMdev] #define LLVM_ASM_PREFIX_CHAR '\1' to make code more readable?
Hi,
llvm, clang and llvm-gcc contain numerous references to 1, '\1',
'\01', '\001', "\01" and "\01foo". This makes it difficult for one to
find all occurences of this prefix character and lacks a central place
where the prefix could be documented. (See for example
http://llvm.org/bugs/show_bug.cgi?id=5480 )
How about adding a #define for this prefix?