search for: 101100_l

Displaying 6 results from an estimated 6 matches for "101100_l".

2015 Jan 22
3
[PATCH 1/2] configure: look for the oUnit OCaml module
It will be used for the OCaml unit tests. --- configure.ac | 5 +++++ 1 file changed, 5 insertions(+) diff --git a/configure.ac b/configure.ac index e0fb481..e360bbb 100644 --- a/configure.ac +++ b/configure.ac @@ -1120,6 +1120,7 @@ AS_IF([test "x$OCAMLC" != "xno"],[ ]) OCAML_PKG_gettext=no +OCAML_PKG_oUnit=no AS_IF([test "x$OCAMLC" != "xno"],[ #
2015 Jan 22
0
[PATCH 2/2] mllib: convert common_utils_tests to oUnit
...resize ~prog 100000_L "+200%"); + assert_equal_int64 400000_L (parse_resize ~prog 100000_L "+300%"); (* Implementation rounds numbers so that only a single digit after * the decimal point is significant. *) - assert (parse_resize ~prog 100000_L "+1.1%" = 101100_L); - assert (parse_resize ~prog 100000_L "+1.12%" = 101100_L) + assert_equal_int64 101100_L (parse_resize ~prog 100000_L "+1.1%"); + assert_equal_int64 101100_L (parse_resize ~prog 100000_L "+1.12%") (* Test Common_utils.human_size. *) +let test_human_size () = +...
2015 May 11
3
[PATCH 1/2] mllib: Require OUnit2 for tests.
...ze () = +let test_parse_resize ctx = (* For absolute sizes, oldsize is ignored. *) assert_equal_int64 100_L (parse_resize ~prog 100_L "100b"); assert_equal_int64 100_L (parse_resize ~prog 1000_L "100b"); @@ -74,7 +74,7 @@ let test_parse_resize () = assert_equal_int64 101100_L (parse_resize ~prog 100000_L "+1.12%") (* Test Common_utils.human_size. *) -let test_human_size () = +let test_human_size ctx = assert_equal_string "100" (human_size 100_L); assert_equal_string "-100" (human_size (-100_L)); assert_equal_string "1.0K&qu...
2015 May 15
5
[PATCH 0/4] Only tell people to use -v -x when reporting bugs if they're not using those flags.
.. and a lot of refactoring. https://bugzilla.redhat.com/show_bug.cgi?id=1167623 Rich.
2015 May 15
6
[PATCH v2 0/4] Only tell people to use -v -x when reporting bugs if they're not using those flags.
https://bugzilla.redhat.com/show_bug.cgi?id=1167623
2017 Sep 26
5
[PATCH 0/5] Miscellaneous refactoring of common/utils, create common/mltools
Miscellaneous refactoring, but the main one is to rename mllib/ as common/mltools/ Rich.