Junxiao Bi
2015-Oct-28 04:04 UTC
[Ocfs2-devel] [PATCH] ocfs2: add uuid to ocfs2 thread name for problem analysis
On 10/27/2015 07:39 PM, Joseph Qi wrote:> Hi Junxiao, >...>>> diff --git a/fs/ocfs2/dlm/dlmrecovery.c b/fs/ocfs2/dlm/dlmrecovery.c >>> index a43f9ef..570509e 100644 >>> --- a/fs/ocfs2/dlm/dlmrecovery.c >>> +++ b/fs/ocfs2/dlm/dlmrecovery.c >>> @@ -205,7 +205,7 @@ int dlm_launch_recovery_thread(struct dlm_ctxt *dlm) >>> mlog(0, "starting dlm recovery thread...\n"); >>> >>> dlm->dlm_reco_thread_task = kthread_run(dlm_recovery_thread, dlm, >>> - "dlm_reco_thread"); >>> + "dlm_reco_thread-%s", dlm->name); >> Indeed max length of task name is 16 bytes, and "dlm_reco_thread" plus >> '\0' have taken all the space. So indeed above code is useless. Can we >> rename this name and maybe other one(like "dlm_thread") to leave more >> space for domain marker? >> > Yes, you are right. For dlm_reco_thread it won't print any uuid bytes. > I put it here just for code consistency. > It is really hard for me to rename it to a better one:) > Any suggestions?How about this? dlmwq-xxxx dlmrec-xxxx dlm-xxxx o2dc-xxxx o2cmt-xxx o2rec-xxx Thanks, Junxiao.> > Thanks, > Joseph >
Joseph Qi
2015-Oct-28 06:18 UTC
[Ocfs2-devel] [PATCH] ocfs2: add uuid to ocfs2 thread name for problem analysis
On 2015/10/28 12:04, Junxiao Bi wrote:> On 10/27/2015 07:39 PM, Joseph Qi wrote: >> Hi Junxiao, >> > ... >>>> diff --git a/fs/ocfs2/dlm/dlmrecovery.c b/fs/ocfs2/dlm/dlmrecovery.c >>>> index a43f9ef..570509e 100644 >>>> --- a/fs/ocfs2/dlm/dlmrecovery.c >>>> +++ b/fs/ocfs2/dlm/dlmrecovery.c >>>> @@ -205,7 +205,7 @@ int dlm_launch_recovery_thread(struct dlm_ctxt *dlm) >>>> mlog(0, "starting dlm recovery thread...\n"); >>>> >>>> dlm->dlm_reco_thread_task = kthread_run(dlm_recovery_thread, dlm, >>>> - "dlm_reco_thread"); >>>> + "dlm_reco_thread-%s", dlm->name); >>> Indeed max length of task name is 16 bytes, and "dlm_reco_thread" plus >>> '\0' have taken all the space. So indeed above code is useless. Can we >>> rename this name and maybe other one(like "dlm_thread") to leave more >>> space for domain marker? >>> >> Yes, you are right. For dlm_reco_thread it won't print any uuid bytes. >> I put it here just for code consistency. >> It is really hard for me to rename it to a better one:) >> Any suggestions? > How about this? > > dlmwq-xxxx > dlmrec-xxxx > dlm-xxxx > o2dc-xxxx > o2cmt-xxx > o2rec-xxx >Thanks very much for your advice. But from our experience, it is usual that we can distinguish the messages if plus 3 uuid bytes. So rename all of them may not be necessary. Could we only rename "dlm_reco_thread" to "dlm_reco-xxx"? Thanks, Joseph> Thanks, > Junxiao. > >> >> Thanks, >> Joseph >> > > >