Hans de Goede
2017-May-26 07:35 UTC
[Nouveau] [PATCH] drm/nouveau: Remove no longer needed local ACPI_VIDEO_NOTIFY_PROBE define
The local #define of ACPI_VIDEO_NOTIFY_PROBE was only added temporarily to avoid a dependency between the acpi and nouveau trees while merging. This is now properly defined in acpi/video.h and the local #define can be dropped. Signed-off-by: Hans de Goede <hdegoede at redhat.com> --- drivers/gpu/drm/nouveau/nouveau_display.c | 9 --------- 1 file changed, 9 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_display.c b/drivers/gpu/drm/nouveau/nouveau_display.c index 549763f5e17d..70de2079b2cc 100644 --- a/drivers/gpu/drm/nouveau/nouveau_display.c +++ b/drivers/gpu/drm/nouveau/nouveau_display.c @@ -369,15 +369,6 @@ nouveau_display_hpd_work(struct work_struct *work) #ifdef CONFIG_ACPI -/* - * Hans de Goede: This define belongs in acpi/video.h, I've submitted a patch - * to the acpi subsys to move it there from drivers/acpi/acpi_video.c . - * This should be dropped once that is merged. - */ -#ifndef ACPI_VIDEO_NOTIFY_PROBE -#define ACPI_VIDEO_NOTIFY_PROBE 0x81 -#endif - static int nouveau_display_acpi_ntfy(struct notifier_block *nb, unsigned long val, void *data) -- 2.13.0
Hans de Goede
2017-Jun-21 13:19 UTC
[Nouveau] drm/nouveau: Remove no longer needed local ACPI_VIDEO_NOTIFY_PROBE define
Hi, On 26-05-17 09:35, Hans De Goede wrote:> The local #define of ACPI_VIDEO_NOTIFY_PROBE was only added temporarily > to avoid a dependency between the acpi and nouveau trees while merging. > > This is now properly defined in acpi/video.h and the local #define can > be dropped. > > Signed-off-by: Hans de Goede <hdegoede at redhat.com>ping, what is the status of this patch ? Regards, Hans> --- > drivers/gpu/drm/nouveau/nouveau_display.c | 9 --------- > 1 file changed, 9 deletions(-) > > diff --git a/drivers/gpu/drm/nouveau/nouveau_display.c b/drivers/gpu/drm/nouveau/nouveau_display.c > index 549763f5e17d..70de2079b2cc 100644 > --- a/drivers/gpu/drm/nouveau/nouveau_display.c > +++ b/drivers/gpu/drm/nouveau/nouveau_display.c > @@ -369,15 +369,6 @@ nouveau_display_hpd_work(struct work_struct *work) > > #ifdef CONFIG_ACPI > > -/* > - * Hans de Goede: This define belongs in acpi/video.h, I've submitted a patch > - * to the acpi subsys to move it there from drivers/acpi/acpi_video.c . > - * This should be dropped once that is merged. > - */ > -#ifndef ACPI_VIDEO_NOTIFY_PROBE > -#define ACPI_VIDEO_NOTIFY_PROBE 0x81 > -#endif > - > static int > nouveau_display_acpi_ntfy(struct notifier_block *nb, unsigned long val, > void *data) >
Pierre Moreau
2017-Jul-22 11:54 UTC
[Nouveau] drm/nouveau: Remove no longer needed local ACPI_VIDEO_NOTIFY_PROBE define
Reviewed-by: Pierre Moreau <pierre.morrow at free.fr> On 2017-06-21 — 15:19, Hans de Goede wrote:> Hi, > > On 26-05-17 09:35, Hans De Goede wrote: > > The local #define of ACPI_VIDEO_NOTIFY_PROBE was only added temporarily > > to avoid a dependency between the acpi and nouveau trees while merging. > > > > This is now properly defined in acpi/video.h and the local #define can > > be dropped. > > > > Signed-off-by: Hans de Goede <hdegoede at redhat.com> > > ping, what is the status of this patch ? > > Regards, > > Hans > > > > --- > > drivers/gpu/drm/nouveau/nouveau_display.c | 9 --------- > > 1 file changed, 9 deletions(-) > > > > diff --git a/drivers/gpu/drm/nouveau/nouveau_display.c b/drivers/gpu/drm/nouveau/nouveau_display.c > > index 549763f5e17d..70de2079b2cc 100644 > > --- a/drivers/gpu/drm/nouveau/nouveau_display.c > > +++ b/drivers/gpu/drm/nouveau/nouveau_display.c > > @@ -369,15 +369,6 @@ nouveau_display_hpd_work(struct work_struct *work) > > #ifdef CONFIG_ACPI > > -/* > > - * Hans de Goede: This define belongs in acpi/video.h, I've submitted a patch > > - * to the acpi subsys to move it there from drivers/acpi/acpi_video.c . > > - * This should be dropped once that is merged. > > - */ > > -#ifndef ACPI_VIDEO_NOTIFY_PROBE > > -#define ACPI_VIDEO_NOTIFY_PROBE 0x81 > > -#endif > > - > > static int > > nouveau_display_acpi_ntfy(struct notifier_block *nb, unsigned long val, > > void *data) > > > _______________________________________________ > dri-devel mailing list > dri-devel at lists.freedesktop.org > https://lists.freedesktop.org/mailman/listinfo/dri-devel-------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 833 bytes Desc: not available URL: <https://lists.freedesktop.org/archives/nouveau/attachments/20170722/fb3abe6f/attachment.sig>
Apparently Analagous Threads
- [PATCH] drm/nouveau: Remove no longer needed local ACPI_VIDEO_NOTIFY_PROBE define
- drm/nouveau: Remove no longer needed local ACPI_VIDEO_NOTIFY_PROBE define
- [PATCH] drm/nouveau: Remove duplicate ACPI_VIDEO_NOTIFY_PROBE definition
- [PATCH] drm/nouveau: Intercept ACPI_VIDEO_NOTIFY_PROBE
- [PATCH 1/2] drm/nouveau: Rename acpi_work to hpd_work