Arnd Bergmann
2017-Jun-09 10:38 UTC
[Nouveau] [PATCH] drm/nouveau: use proper prototype in nouveau_pmops_runtime() definition
There is a prototype for this function in the header, but the function itself lacks a 'void' in the argument list, causing a harmless warning when building with 'make W=1': drivers/gpu/drm/nouveau/nouveau_drm.c: In function 'nouveau_pmops_runtime': drivers/gpu/drm/nouveau/nouveau_drm.c:730:1: error: old-style function definition [-Werror=old-style-definition] Fixes: 321f5c5f2c49 ("drm/nouveau: replace multiple open-coded runpm support checks with function") Signed-off-by: Arnd Bergmann <arnd at arndb.de> --- drivers/gpu/drm/nouveau/nouveau_drm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_drm.c b/drivers/gpu/drm/nouveau/nouveau_drm.c index 7acd1cf8c5a6..90757af9bc73 100644 --- a/drivers/gpu/drm/nouveau/nouveau_drm.c +++ b/drivers/gpu/drm/nouveau/nouveau_drm.c @@ -727,7 +727,7 @@ nouveau_pmops_thaw(struct device *dev) } bool -nouveau_pmops_runtime() +nouveau_pmops_runtime(void) { if (nouveau_runtime_pm == -1) return nouveau_is_optimus() || nouveau_is_v1_dsm(); -- 2.9.0
Possibly Parallel Threads
- [PATCH][drm-next] drm/nouveau: fix non-ANSI function declaration of nouveau_pmops_runtime
- [PATCH] drm: compute runpm on load, don't register autosuspend for non-runpm
- [PATCH] drm: compute runpm on load, don't register autosuspend for non-runpm
- [PATCH RFC] nouveau: Add support for Gmux _DSM method
- [PATCH 3/5] drm/nouveau: Don't register Thunderbolt eGPU with vga_switcheroo