On Fri, Mar 17, 2023 at 10:49:27AM +0100, Eugenio Perez Martin
wrote:>On Thu, Mar 16, 2023 at 5:07?PM Stefano Garzarella <sgarzare at
redhat.com> wrote:
>>
>> On Fri, Mar 3, 2023 at 3:39?PM Eugenio Perez Martin <eperezma at
redhat.com> wrote:
>> >
>> > On Thu, Mar 2, 2023 at 12:35 PM Stefano Garzarella <sgarzare at
redhat.com> wrote:
>> > >
>> > > vDPA supports the possibility to use user VA in the iotlb
messages.
>> > > So, let's add support for user VA in vringh to use it in
the vDPA
>> > > simulators.
>> > >
>> > > Signed-off-by: Stefano Garzarella <sgarzare at
redhat.com>
>> > > ---
>> > >
>> > > Notes:
>> > > v2:
>> > > - replace kmap_atomic() with kmap_local_page() [see
previous patch]
>> > > - fix cast warnings when build with W=1 C=1
>> > >
>> > > include/linux/vringh.h | 5 +-
>> > > drivers/vdpa/mlx5/net/mlx5_vnet.c | 2 +-
>> > > drivers/vdpa/vdpa_sim/vdpa_sim.c | 4 +-
>> > > drivers/vhost/vringh.c | 247
++++++++++++++++++++++++------
>> > > 4 files changed, 205 insertions(+), 53 deletions(-)
>> > >
>>
>> [...]
>>
>> >
>> > It seems to me iotlb_translate_va and iotlb_translate_pa are very
>> > similar, their only difference is that the argument is that iov is
>> > iovec instead of bio_vec. And how to fill it, obviously.
>> >
>> > It would be great to merge both functions, only differing with a
>> > conditional on vrh->use_va, or generics, or similar. Or, if
following
>> > the style of the rest of vringh code, to provide a callback to
fill
>> > iovec (although I like conditional more).
>> >
>> > However I cannot think of an easy way to perform that without long
>> > macros or type erasure.
>>
>> Thank you for pushing me :-)
>> I finally managed to avoid code duplication (partial patch attached,
>> but not yet fully tested).
>>
>> @Jason: with this refactoring I removed copy_to_va/copy_to_pa, so I
>> also avoided getu16_iotlb_va/pa.
>>
>> I will send the full patch in v3, but I would like to get your opinion
>> first ;-)
>>
>>
>>
>> diff --git a/drivers/vhost/vringh.c b/drivers/vhost/vringh.c
>> index 0ba3ef809e48..71dd67700e36 100644
>> --- a/drivers/vhost/vringh.c
>> +++ b/drivers/vhost/vringh.c
>> @@ -1096,8 +1096,7 @@ EXPORT_SYMBOL(vringh_need_notify_kern);
>>
>> static int iotlb_translate(const struct vringh *vrh,
>> u64 addr, u64 len, u64 *translated,
>> - struct bio_vec iov[],
>> - int iov_size, u32 perm)
>> + void *iov, int iov_size, bool iovec, u32
perm)
>
>I think this is an improvement, but we're doing type erasure here. I
>don't think it is a big deal since the function is not exported,
it's
>pretty contained in this file, so I'd ack this version too. I'm just
>throwing ideas here:
>
>a) typedef the union {iovec, bio_vec} and use that type in the parameter.
>
>As a drawback, that union feels out of place in this file. Is this the
>only place where it is needed? I don't see other similar uses in the
>kernel.
iov_iter has something similar, but they are const pointers, so IIUC
it is not supposed to be used to set the bvec contents, just iterate it.
Anyway I thought something similar and should be doable, but since
it was internal API I went to type erasure.
>
>b) To convert from iov to bio_iov at return
>The drawback is the extra processing if the compiler is not smart
>enough to inline it. I prefer the previous one but I didn't want to
>omit it, just in case.
Yep, I prefer too the previous one, so let's go in that direction for
v3 ;-)
Thanks,
Stefano