Dan Carpenter
2021-Nov-15 12:35 UTC
[Bridge] [PATCH] net: bridge: Slightly optimize 'find_portno()'
On Sun, Nov 14, 2021 at 08:02:35PM +0100, Christophe JAILLET wrote:> The 'inuse' bitmap is local to this function. So we can use the > non-atomic '__set_bit()' to save a few cycles. > > While at it, also remove some useless {}.I like the {} and tend to add it in new code. There isn't a rule about this one way or the other. regards, dan carpenter
Christophe JAILLET
2021-Nov-15 18:35 UTC
[Bridge] [PATCH] net: bridge: Slightly optimize 'find_portno()'
Le 15/11/2021 ? 13:35, Dan Carpenter a ?crit?:> On Sun, Nov 14, 2021 at 08:02:35PM +0100, Christophe JAILLET wrote: >> The 'inuse' bitmap is local to this function. So we can use the >> non-atomic '__set_bit()' to save a few cycles. >> >> While at it, also remove some useless {}. > > I like the {} and tend to add it in new code. There isn't a rule about > this one way or the other. > > regards, > dan carpenter > > >Hi Dan, - checkpatch prefers the style without {} - Usually, greg k-h and Joe Perches give feed-back that extra {} should be removed. - in https://www.kernel.org/doc/html/v5.13/process/coding-style.html, after "Rationale: K&R": "Do not unnecessarily use braces where a single statement will do." My own preference is to have {}. It is the standard used on another project I work on (i.e. httpd) and it helps when you add some code (it avoids unexpected behavior if you forget to add some missing {}) My understanding is that on the HUGE code base of Linux, emphasis is put on saving some lines of code, reducing the length of lines and avoiding the need to read some extra char. I'm also fine with it. CJ
Dan Carpenter
2021-Nov-16 08:32 UTC
[Bridge] [PATCH] net: bridge: Slightly optimize 'find_portno()'
On Mon, Nov 15, 2021 at 07:35:48PM +0100, Christophe JAILLET wrote:> Le 15/11/2021 ? 13:35, Dan Carpenter a ?crit?: > > On Sun, Nov 14, 2021 at 08:02:35PM +0100, Christophe JAILLET wrote: > > > The 'inuse' bitmap is local to this function. So we can use the > > > non-atomic '__set_bit()' to save a few cycles. > > > > > > While at it, also remove some useless {}. > > > > I like the {} and tend to add it in new code. There isn't a rule about > > this one way or the other. > >[ heavily snipped ]> > - checkpatch prefers the style without {}Not for these.> - Usually, greg k-h and Joe Perches give feed-back that extra {} should be > removed.I can't find any reference to that.> - in https://www.kernel.org/doc/html/v5.13/process/coding-style.html, after > "Rationale: K&R": > "Do not unnecessarily use braces where a single statement will do."There are exceptions for readability. For example, mutiline indents get it whether they need or not. Do while statements get braces. Quite a lot of people don't use braces for list_for_each() unless it's required, definitely, but I think it's allowable. regards, dan carpenter