Hello all,
I have a repetitive kernel panic on FreeBSD-4.9 [fresh installed from
CD - no CVS upgrades]
========================panic: timeout table full
syncing disks... panic: timeout table full
Uptime: 1d0h18m7s
Automatic reboot in 15 seconds - press a key on the console to abort
Rebooting...
========================
This has happened almost once every day at random times since the
machine was put into action
There are no nasty errors or warnings in the syslog all.log/dmesg
There are no obvious patterns or chain of events that build up
beforehand
It happens when running GENERIC kernel and on different custom kernels
It happens when disks in PIO4 Mode or in UDMA mode
It happens - randomly - when busy or idle
This is the first time it as auto-rebooted - previous times it just
hangs @ syncing disks... and needs power-cycling.
The disks were in PIO4 mode for this first auto-reboot
So I will enable crash-dumps - I guess I may be able to find the
culprit with gdb
SoftUpdates anabled, ata write cache off, ata tagged Q off
maxusers=512 NMBCLUSERS=32768
I have read about these timeout panics in 'man crash' and looking at
the kernel source, a timeout can be called by many things and that when
there are none free, it panics :(
I have worked out the value of ncallouts on my system its:
ncallout = 16 + maxproc + maxfiles;
= 73764 16 + 8212 + 65536
* [Q] Does anyone know what are the likely reasons that would case BSD
to runout of timeouts/ncallouts - 73764 worth?
man 9 timeout: timeout -- execute a function after a specified length
of time.
* [Q] ??: either the number of free ncallouts is depleating over time
or something has stopped responding, causing a rapid increase in the
number of timeouts called or something has stopped clearing its timeout
handles - a bad driver?
* [Q] Does somebody know of a method to ask the kernel how many
timeouts are assigned and what called them?
To be able to find out how many are left/being used and therefore
workout the rate of depletion would be helpful in debugging - AND to
'throw in the towel' and reboot safely before it dies!
Can this be done? [some inquiry code or a kernel patch]
Is there something already in FreeBSD that can do this?
The only quirk i see at boot is this in dmesg:
pci0: <unknown card> (vendor=0x8086, dev=0x24c3) at 31.3 irq 7
And sometimes (note: not all the time) this message after boot or
midway thru the day:
stray irq 7
* [Q] This unknown card at irq7 I imagine from vendor this is the
onboard Intel SMBus/I2C bridge. Could this play a part in this timeout
panic?
* [Q] is my kernel config at fault? (though GENERIC still paniced)
* [Q] I have a 70 gig UFS+S filesystem (27067418 used inodes) is it
normal for it to take an hour to fsck after the panic?
I welcome suggestions to debug/fix this and i can supply more info it
it helps
ells...
About the system
-----------------
FreeBSD book 4.9-RELEASE FreeBSD 4.9-RELEASE #0: Wed Feb 4 12:33:00
GMT 2004
Mem 512Mb
Intel P4 on a Tyan Trinity i845E [S2099GNNR]
2 x 120mb IDE Seagate ST3120026A/3.06 on Promise TX2 ATA133 RAID1
Inbuilt ethernet devices: Intel fxp and em
Hardware is new
Runs apache/php/djbdns/qmail+spamc+clamav/Courier-IMAP/proftpd
Its very fast and the load average 0.02 + rarely goes over 1.0 + runs
with approx 300Mb free
Its not busy - i can compile kernels and packages at ease
networking: no errors in stats
BSD on the system - dmesg + kernel + sysctl output
---------------------------------------------------
FreeBSD 4.9-RELEASE #0: Wed Feb 4 12:33:00 GMT 2004
root@book:/usr/src/sys/compile/BOOKV2
Timecounter "i8254" frequency 1193182 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.66GHz (2659.10-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0xf29 Stepping = 9
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE
,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory = 536805376 (524224K bytes)
avail memory = 518729728 (506572K bytes)
Preloaded elf kernel "kernel" at 0xc02ef000.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 12 entries at 0xc00fde90
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82845 Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> mem 0xe0000000-0xe3ffffff at
device 0.0 on pci0
pcib1: <Intel 82845 PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pcib2: <Intel 82801BA/BAM (ICH2) Hub to PCI bridge> at device 30.0 on
pci0
pci2: <PCI bus> on pcib2
pci2: <ATI Mach64-GR graphics accelerator> at 1.0 irq 12
atapci0: <Promise TX2 ATA133 controller> port
0xa400-0xa40f,0xa000-0xa003,0x9c00-0x9c07,0x9800-0x9803,0x9400-0x9407
mem 0xe6040000-0xe6043fff irq 15 at device 2.0 on pci2
ata2: at 0x9400 on atapci0
ata3: at 0x9c00 on atapci0
fxp0: <Intel 82801DB (ICH4) Pro/100 VE Ethernet> port 0xa800-0xa83f mem
0xe6045000-0xe6045fff irq 11 at device 8.0 on pci2
fxp0: Ethernet address 00:e0:81:60:8e:49
inphy0: <i82562EM 10/100 media interface> on miibus0
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.16> port
0xac00-0xac3f mem 0xe6020000-0xe603ffff,0xe6000000-0xe601ffff irq 10 at
device 10.0 on pci2
em0: Speed:N/A Duplex:N/A
isab0: <PCI to ISA bridge (vendor=8086 device=24c0)> at device 31.0 on
pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH4 ATA100 controller> port
0xf000-0xf00f,0-0x3,0-0x7,0-0x3,0-0x7 irq 0 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
pci0: <unknown card> (vendor=0x8086, dev=0x24c3) at 31.3 irq 7
orm0: <Option ROMs> at iomem
0xc0000-0xc7fff,0xc8000-0xd07ff,0xd1000-0xd27ff,0xd3000-0xd47ff on isa0
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A, console
ppc0: parallel port not found.
ar0: 114473MB <ATA RAID1 array> [14593/255/63] status: READY subdisks:
0 READY ad4: 114473MB <ST3120026A> [232581/16/63] at ata2-master
UDMA100
1 READY ad6: 114473MB <ST3120026A> [232581/16/63] at
ata3-master UDMA100
acd0: DVD-ROM <SAMSUNG DVD-ROM SD-616E> at ata0-master PIO4
Mounting root from ufs:/dev/ar0s1a
em0: Link is up 100 Mbps Full Duplex
Current Kernel
--------------
machine i386
cpu I686_CPU
ident BOOKV2
maxusers 512
options NMBCLUSTERS=32768
makeoptions DEBUG=-g #Build kernel with gdb(1) debug
symbols
makeoptions COPTFLAGS="-O -pipe"
options INET #InterNETworking
options FFS #Berkeley Fast Filesystem
options FFS_ROOT #FFS usable as root device
[keep this!]
options SOFTUPDATES #Enable FFS soft updates support
options UFS_DIRHASH #Improve performance on big
directories
options MFS #Memory Filesystem
options MSDOSFS #MSDOS Filesystem
options CD9660 #ISO 9660 Filesystem
options CD9660_ROOT #CD-ROM usable as root, CD9660
required
options PROCFS #Process filesystem
options COMPAT_43 #Compatible with BSD 4.3 [KEEP
THIS!]
options UCONSOLE #Allow users to grab the console
options USERCONFIG #boot -c editor
options VISUAL_USERCONFIG #visual boot -c editor
options KTRACE #ktrace(1) support
options SYSVSHM #SYSV-style shared memory
options SYSVMSG #SYSV-style message queues
options SYSVSEM #SYSV-style semaphores
options P1003_1B #Posix P1003_1B real-time
extensions
options QUOTA #enable disk quotas [emm]
options _KPOSIX_PRIORITY_SCHEDULING
options ICMP_BANDLIM #Rate limit bad replies
options KBD_INSTALL_CDEV # install a CDEV entry in /dev
options AHC_REG_PRETTY_PRINT # Print register bitfields in
debug
options AHD_REG_PRETTY_PRINT # Print register bitfields in
debug
device isa
device eisa
device pci
device ata0 at isa? port IO_WD1 irq 14
device ata1 at isa? port IO_WD2 irq 15
device ata
device atadisk # ATA disk drives
device atapicd # ATAPI CDROM drives
options ATA_STATIC_ID #Static device numbering
device atkbdc0 at isa? port IO_KBD
device atkbd0 at atkbdc? irq 1
device psm0 at atkbdc? irq 12
device vga0 at isa?
pseudo-device splash
device sc0 at isa? flags 0x100
device agp # support several AGP chipsets
device npx0 at nexus? port IO_NPX irq 13
device apm0 at nexus? disable flags 0x20 # Advanced Power
Management
device sio0 at isa? port IO_COM1 flags 0x10 irq 4
device ppc0 at isa? irq 7
device ppbus # Parallel port bus (required)
device lpt # Printer
device ppi # Parallel port interface device
device em # Intel PRO/1000 adapter Gigabit
Ethernet Card (``Wiseman'')
device miibus # MII bus support
device fxp # Intel EtherExpress PRO/100B (82557,
82558)
pseudo-device loop # Network loopback
pseudo-device ether # Ethernet support
pseudo-device ppp 1 # Kernel PPP
pseudo-device tun # Packet tunnel.
pseudo-device pty # Pseudo-ttys (telnet etc)
pseudo-device md # Memory "disks"
pseudo-device bpf #Berkeley packet filter
device uhci # UHCI PCI->USB interface
device ohci # OHCI PCI->USB interface
device usb # USB Bus (required)
device ugen # Generic
device uhid # "Human Interface Devices"
device ukbd # Keyboard
Kernel Variables
-----------------
kern.ostype: FreeBSD
kern.osrelease: 4.9-RELEASE
kern.osrevision: 199506
kern.version: FreeBSD 4.9-RELEASE #0: Wed Feb 4 12:33:00 GMT 2004
root@book:/usr/src/sys/compile/BOOKV2
kern.maxvnodes: 40271
kern.maxproc: 8212
kern.maxfiles: 65536
kern.argmax: 65536
kern.securelevel: -1
kern.hostname: book
kern.hostid: 0
kern.clockrate: { hz = 100, tick = 10000, tickadj = 5, profhz = 1024,
stathz = 128 }
kern.posix1version: 199309
kern.ngroups: 16
kern.job_control: 1
kern.saved_ids: 0
kern.boottime: { sec = 1076117668, usec = 193451 } Sat Feb 7 01:34:28
2004
kern.domainname:
kern.osreldate: 490000
kern.bootfile: /kernel
kern.maxfilesperproc: 14781
kern.maxprocperuid: 7390
kern.dumpdev:
kern.ipc.maxsockbuf: 262144
kern.ipc.sockbuf_waste_factor: 8
kern.ipc.somaxconn: 2048
kern.ipc.max_linkhdr: 16
kern.ipc.max_protohdr: 40
kern.ipc.max_hdr: 56
kern.ipc.max_datalen: 156
kern.ipc.nmbclusters: 32768
kern.ipc.msgmax: 16384
kern.ipc.msgmni: 40
kern.ipc.msgmnb: 2048
kern.ipc.msgtql: 40
kern.ipc.msgssz: 8
kern.ipc.msgseg: 2048
kern.ipc.semmap: 30
kern.ipc.semmni: 10
kern.ipc.semmns: 60
kern.ipc.semmnu: 30
kern.ipc.semmsl: 60
kern.ipc.semopm: 100
kern.ipc.semume: 10
kern.ipc.semusz: 92
kern.ipc.semvmx: 32767
kern.ipc.semaem: 16384
kern.ipc.shmmax: 33554432
kern.ipc.shmmin: 1
kern.ipc.shmmni: 192
kern.ipc.shmseg: 128
kern.ipc.shmall: 8192
kern.ipc.shm_use_phys: 0
kern.ipc.mbuf_wait: 32
kern.ipc.mbtypes: 330 324 2 0 0 0 0 0 0 0 0 0 0 0 0 0
kern.ipc.nmbufs: 131072
kern.ipc.m_clreflimithits: 0
kern.ipc.mcl_pool_max: 0
kern.ipc.mcl_pool_now: 0
kern.ipc.maxsockets: 32768
kern.dummy: 0
kern.ps_strings: 3217031152
kern.usrstack: 3217031168
kern.logsigexit: 1
kern.fallback_elf_brand: -1
kern.init_path: /sbin/init:/sbin/oinit:/sbin/init.bak:/stand/sysinstall
kern.module_path: /;/boot/;/modules/
kern.acct_suspend: 2
kern.acct_resume: 4
kern.acct_chkfreq: 15
kern.cp_time: 1308 0 510 283 107085
kern.timecounter.method: 0
kern.timecounter.hardware: i8254
kern.openfiles: 479
kern.kq_calloutmax: 4096
kern.ps_arg_cache_limit: 256
kern.ps_argsopen: 1
kern.randompid: 0
kern.maxusers: 512
kern.ps_showallprocs: 1
kern.shutdown.poweroff_delay: 5000
kern.shutdown.kproc_shutdown_wait: 60
kern.sugid_coredump: 0
kern.coredump: 1
kern.corefile: %N.core
kern.quantum: 100000
kern.ccpu: 1948
kern.fscale: 2048
kern.devstat.numdevs: 4
kern.devstat.generation: 4
kern.devstat.version: 4
kern.disks: ar0 ad6 ad4 md0
kern.log_wakeups_per_second: 5
kern.log_console_output: 1
kern.msgbuf:
kern.msgbuf_clear: 0
kern.nselcoll: 0
kern.consmute: 0
kern.filedelay: 30
kern.dirdelay: 29
kern.metadelay: 28
kern.minvnodes: 10067
kern.chroot_allow_open_directories: 1
vm.loadavg: { 0.11 0.07 0.02 }
vm.v_free_min: 888
vm.v_free_target: 3800
vm.v_free_reserved: 248
vm.v_inactive_target: 5700
vm.v_cache_min: 3800
vm.v_cache_max: 7600
vm.v_pageout_free_min: 34
vm.pageout_algorithm: 0
vm.swap_enabled: 1
vm.swap_async_max: 4
vm.swap_idle_threshold1: 2
vm.swap_idle_threshold2: 10
vm.v_free_severe: 568
vm.v_intrans_coll: 0
vm.v_intrans_wait: 0
vm.stats.sys.v_swtch: 49497
vm.stats.sys.v_trap: 147294
vm.stats.sys.v_syscall: 547128
vm.stats.sys.v_intr: 223006
vm.stats.sys.v_soft: 20194
vm.stats.vm.v_vm_faults: 144820
vm.stats.vm.v_cow_faults: 21230
vm.stats.vm.v_cow_optim: 0
vm.stats.vm.v_zfod: 92782
vm.stats.vm.v_ozfod: 92479
vm.stats.vm.v_swapin: 0
vm.stats.vm.v_swapout: 0
vm.stats.vm.v_swappgsin: 0
vm.stats.vm.v_swappgsout: 0
vm.stats.vm.v_vnodein: 1422
vm.stats.vm.v_vnodeout: 1
vm.stats.vm.v_vnodepgsin: 8449
vm.stats.vm.v_vnodepgsout: 1
vm.stats.vm.v_intrans: 6
vm.stats.vm.v_reactivated: 507
vm.stats.vm.v_pdwakeups: 0
vm.stats.vm.v_pdpages: 0
vm.stats.vm.v_dfree: 0
vm.stats.vm.v_pfree: 64152
vm.stats.vm.v_tfree: 105796
vm.stats.vm.v_page_size: 4096
vm.stats.vm.v_page_count: 128238
vm.stats.vm.v_free_reserved: 248
vm.stats.vm.v_free_target: 3800
vm.stats.vm.v_free_min: 888
vm.stats.vm.v_free_count: 86943
vm.stats.vm.v_wire_count: 12044
vm.stats.vm.v_active_count: 22417
vm.stats.vm.v_inactive_target: 5700
vm.stats.vm.v_inactive_count: 6482
vm.stats.vm.v_cache_count: 352
vm.stats.vm.v_cache_min: 3800
vm.stats.vm.v_cache_max: 7600
vm.stats.vm.v_pageout_free_min: 34
vm.stats.vm.v_interrupt_free_min: 2
vm.stats.vm.v_forks: 835
vm.stats.vm.v_vforks: 131
vm.stats.vm.v_rforks: 0
vm.stats.vm.v_kthreads: 6
vm.stats.vm.v_forkpages: 94376
vm.stats.vm.v_vforkpages: 5971
vm.stats.vm.v_rforkpages: 0
vm.stats.vm.v_kthreadpages: 0
vm.stats.misc.zero_page_count: 69549
vm.stats.misc.cnt_prezero: 162032
vm.max_proc_mmap: 36476
vm.msync_flush_flags: 3
vm.max_launder: 32
vm.pageout_stats_max: 3800
vm.pageout_full_stats_interval: 20
vm.pageout_stats_interval: 5
vm.pageout_stats_free_max: 5
vm.swap_idle_enabled: 0
vm.defer_swapspace_pageouts: 0
vm.disable_swapspace_pageouts: 0
vm.pageout_lock_miss: 0
vm.zone:
ITEM SIZE LIMIT USED FREE REQUESTS
PIPE: 160, 0, 68, 136, 1134
SWAPMETA: 160, 64119, 0, 0, 0
unpcb: 160, 0, 89, 36, 281
ripcb: 192, 32768, 0, 21, 1
syncache: 160, 15359, 0, 51, 298
tcpcb: 576, 32768, 47, 24, 369
udpcb: 192, 32768, 8, 34, 603
socket: 192, 32768, 144, 48, 1255
KNOTE: 64, 0, 0, 128, 60
DIRHASH: 1024, 0, 350, 6, 350
VNODE: 192, 0, 5891, 45, 5891
NAMEI: 1024, 0, 0, 24, 87469
VMSPACE: 192, 0, 83, 45, 966
PROC: 416, 0, 89, 58, 972
DP fakepg: 64, 0, 0, 0, 0
PV ENTRY: 28, 1904494, 75802, 55245, 497783
MAP ENTRY: 48, 0, 3522, 431, 53097
KMAP ENTRY: 48, 49005, 365, 104, 2891
MAP: 108, 0, 7, 3, 7
VM OBJECT: 92, 0, 4892, 116, 22432
vm.zone_kmem_pages: 28
vm.zone_kmem_kvaspace: 102473728
vm.zone_kern_pages: 564
vm.kvm_size: 1073737728
vm.kvm_free: 457175040
vfs.ufs.dirhash_minsize: 2560
vfs.ufs.dirhash_maxmem: 2097152
vfs.ufs.dirhash_mem: 374105
vfs.ufs.dirhash_docheck: 0
vfs.numdirtybuffers: 29
vfs.lodirtybuffers: 500
vfs.hidirtybuffers: 1001
vfs.numfreebuffers: 3893
vfs.lofreebuffers: 223
vfs.hifreebuffers: 446
vfs.runningbufspace: 0
vfs.lorunningspace: 524288
vfs.hirunningspace: 1048576
vfs.maxbufspace: 64290816
vfs.hibufspace: 63635456
vfs.lobufspace: 63569920
vfs.bufspace: 54050816
vfs.maxmallocbufspace: 3181772
vfs.bufmallocspace: 1292288
vfs.getnewbufcalls: 4315
vfs.getnewbufrestarts: 0
vfs.vmiodirenable: 1
vfs.bufdefragcnt: 0
vfs.buffreekvacnt: 0
vfs.bufreusecnt: 3299
vfs.cache.numneg: 386
vfs.cache.numcache: 6195
vfs.cache.numcalls: 324101
vfs.cache.dothits: 8076
vfs.cache.dotdothits: 37
vfs.cache.numchecks: 307990
vfs.cache.nummiss: 10949
vfs.cache.nummisszap: 308
vfs.cache.numposzaps: 547
vfs.cache.numposhits: 292146
vfs.cache.numnegzaps: 178
vfs.cache.numneghits: 11860
vfs.cache.numcwdcalls: 838
vfs.cache.numcwdfail1: 0
vfs.cache.numcwdfail2: 0
vfs.cache.numcwdfail3: 0
vfs.cache.numcwdfail4: 0
vfs.cache.numcwdfound: 838
vfs.cache.numfullpathcalls: 29
vfs.cache.numfullpathfail1: 0
vfs.cache.numfullpathfail2: 0
vfs.cache.numfullpathfail3: 0
vfs.cache.numfullpathfail4: 0
vfs.cache.numfullpathfound: 29
vfs.write_behind: 1
vfs.reassignbufcalls: 9306
vfs.reassignbufloops: 0
vfs.reassignbufsortgood: 2552
vfs.reassignbufsortbad: 1990
vfs.reassignbufmethod: 1
vfs.nameileafonly: 0
vfs.timestamp_precision: 0
vfs.usermount: 0
vfs.ffs.doreallocblks: 1
vfs.ffs.doasyncfree: 1
net.local.stream.sendspace: 8192
net.local.stream.recvspace: 8192
net.local.dgram.maxdgram: 2048
net.local.dgram.recvspace: 4096
net.local.inflight: 0
net.inet.ip.portrange.lowfirst: 1023
net.inet.ip.portrange.lowlast: 600
net.inet.ip.portrange.first: 1024
net.inet.ip.portrange.last: 5000
net.inet.ip.portrange.hifirst: 49152
net.inet.ip.portrange.hilast: 65535
net.inet.ip.forwarding: 0
net.inet.ip.redirect: 1
net.inet.ip.ttl: 64
net.inet.ip.rtexpire: 2400
net.inet.ip.rtminexpire: 10
net.inet.ip.rtmaxcache: 128
net.inet.ip.sourceroute: 0
net.inet.ip.intr_queue_maxlen: 50
net.inet.ip.intr_queue_drops: 0
net.inet.ip.accept_sourceroute: 0
net.inet.ip.fastforwarding: 0
net.inet.ip.keepfaith: 0
net.inet.ip.subnets_are_local: 0
net.inet.ip.maxfragpackets: 1024
net.inet.ip.maxfragsperpacket: 16
net.inet.ip.sendsourcequench: 0
net.inet.ip.check_interface: 0
net.inet.icmp.maskrepl: 0
net.inet.icmp.icmplim: 200
net.inet.icmp.drop_redirect: 0
net.inet.icmp.log_redirect: 0
net.inet.icmp.icmplim_output: 1
net.inet.icmp.bmcastecho: 0
net.inet.tcp.rfc1323: 1
net.inet.tcp.rfc1644: 0
net.inet.tcp.mssdflt: 512
net.inet.tcp.keepidle: 7200000
net.inet.tcp.keepintvl: 75000
net.inet.tcp.sendspace: 32768
net.inet.tcp.recvspace: 57344
net.inet.tcp.keepinit: 75000
net.inet.tcp.delacktime: 100
net.inet.tcp.log_in_vain: 0
net.inet.tcp.blackhole: 0
net.inet.tcp.delayed_ack: 1
net.inet.tcp.path_mtu_discovery: 1
net.inet.tcp.slowstart_flightsize: 1
net.inet.tcp.local_slowstart_flightsize: 4
net.inet.tcp.newreno: 1
net.inet.tcp.tcbhashsize: 512
net.inet.tcp.do_tcpdrain: 1
net.inet.tcp.pcbcount: 48
net.inet.tcp.icmp_may_rst: 1
net.inet.tcp.isn_reseed_interval: 0
net.inet.tcp.inflight_enable: 0
net.inet.tcp.inflight_debug: 0
net.inet.tcp.inflight_min: 6144
net.inet.tcp.inflight_max: 1073725440
net.inet.tcp.inflight_stab: 20
net.inet.tcp.syncookies: 1
net.inet.tcp.syncache.bucketlimit: 30
net.inet.tcp.syncache.cachelimit: 15359
net.inet.tcp.syncache.count: 0
net.inet.tcp.syncache.hashsize: 512
net.inet.tcp.syncache.rexmtlimit: 3
net.inet.tcp.msl: 30000
net.inet.tcp.rexmit_min: 1000
net.inet.tcp.rexmit_slop: 200
net.inet.tcp.always_keepalive: 1
net.inet.udp.checksum: 1
net.inet.udp.maxdgram: 9216
net.inet.udp.recvspace: 41600
net.inet.udp.log_in_vain: 0
net.inet.udp.blackhole: 0
net.inet.accf.unloadable: 0
net.inet.raw.maxdgram: 8192
net.inet.raw.recvspace: 8192
net.link.generic.system.ifcount: 4
net.link.ether.inet.prune_intvl: 300
net.link.ether.inet.max_age: 1200
net.link.ether.inet.host_down_time: 20
net.link.ether.inet.maxtries: 5
net.link.ether.inet.useloopback: 1
net.link.ether.inet.proxyall: 0
net.link.ether.inet.log_arp_wrong_iface: 1
net.link.ether.inet.log_arp_movements: 1
net.link.ether.ipfw: 0
debug.mddebug: 0
debug.elf_trace: 0
debug.elf_legacy_coredump: 0
debug.boothowto: -2147479552
debug.free_devt: 0
debug.fdexpand: 36
debug.sizeof.vnode: 168
debug.sizeof.proc: 412
debug.sizeof.specinfo: 68
debug.sizeof.disklabel: 276
debug.sizeof.diskslices: 1820
debug.sizeof.disk: 304
debug.ttydebug: 0
debug.nchash: 65535
debug.ncnegfactor: 16
debug.numneg: 386
debug.numcache: 6195
debug.vfscache: 1
debug.vnsize: 168
debug.ncsize: 36
debug.disablecwd: 0
debug.disablefullpath: 0
debug.numvnodes: 5891
debug.wantfreevnodes: 25
debug.freevnodes: 3066
debug.rush_requests: 0
debug.vnlru_nowhere: 0
debug.bpf_bufsize: 4096
debug.bpf_maxbufsize: 524288
debug.if_tun_debug: 0
debug.max_softdeps: 322168
debug.tickdelay: 2
debug.worklist_push: 0
debug.blk_limit_push: 0
debug.ino_limit_push: 0
debug.blk_limit_hit: 0
debug.ino_limit_hit: 0
debug.sync_limit_hit: 0
debug.indir_blk_ptrs: 10
debug.inode_bitmap: 11
debug.direct_blk_ptrs: 46
debug.dir_entry: 17
debug.dircheck: 0
debug.apm_debug: 0
hw.machine: i386
hw.model: Intel(R) Pentium(R) 4 CPU 2.66GHz
hw.ncpu: 1
hw.byteorder: 1234
hw.physmem: 534208512
hw.usermem: 484876288
hw.pagesize: 4096
hw.floatingpoint: 1
hw.machine_arch: i386
hw.ata.ata_dma: 1
hw.ata.wc: 0
hw.ata.tags: 0
hw.ata.atapi_dma: 0
hw.fxp_rnr: 0
hw.instruction_sse: 0
hw.availpages: 130258
hw.fxp0.int_delay: 1000
hw.fxp0.bundle_max: 6
hw.em0.debug_info: -1
hw.em0.stats: -1
machdep.consdev: { major = 28, minor = 0 }
machdep.adjkerntz: 0
machdep.disable_rtc_set: 0
machdep.wall_cmos_clock: 0
machdep.do_dump: 1
machdep.enable_panic_key: 0
machdep.apm_suspend_delay: 1
machdep.apm_standby_delay: 1
machdep.ispc98: 0
machdep.msgbuf:
machdep.msgbuf_clear: 0
machdep.cpu_idle_hlt: 1
machdep.guessed_bootdev: /dev/wd0s1a
machdep.panic_on_nmi: 1
machdep.i8254_freq: 1193182
machdep.conrclk: 1843200
machdep.conspeed: 9600
user.cs_path: /usr/bin:/bin:/usr/sbin:/sbin:
user.bc_base_max: 99
user.bc_dim_max: 2048
user.bc_scale_max: 99
user.bc_string_max: 1000
user.coll_weights_max: 0
user.expr_nest_max: 32
user.line_max: 2048
user.re_dup_max: 255
user.posix2_version: 199212
user.posix2_c_bind: 0
user.posix2_c_dev: 0
user.posix2_char_term: 0
user.posix2_fort_dev: 0
user.posix2_fort_run: 0
user.posix2_localedef: 0
user.posix2_sw_dev: 0
user.posix2_upe: 0
user.stream_max: 20
user.tzname_max: 255
p1003_1b.asynchronous_io: 0
p1003_1b.mapped_files: 0
p1003_1b.memlock: 0
p1003_1b.memlock_range: 0
p1003_1b.memory_protection: 0
p1003_1b.message_passing: 0
p1003_1b.prioritized_io: 0
p1003_1b.priority_scheduling: 1
p1003_1b.realtime_signals: 0
p1003_1b.semaphores: 0
p1003_1b.fsync: 0
p1003_1b.shared_memory_objects: 0
p1003_1b.synchronized_io: 0
p1003_1b.timers: 0
p1003_1b.aio_listio_max: 0
p1003_1b.aio_max: 0
p1003_1b.aio_prio_delta_max: 0
p1003_1b.delaytimer_max: 0
p1003_1b.mq_open_max: 0
p1003_1b.pagesize: 4096
p1003_1b.rtsig_max: 0
p1003_1b.sem_nsems_max: 0
p1003_1b.sem_value_max: 0
p1003_1b.sigqueue_max: 0
p1003_1b.timer_max: 0
jail.set_hostname_allowed: 1
jail.socket_unixiproute_only: 1
jail.sysvipc_allowed: 0
compat.linux.osname: Linux
compat.linux.osrelease: 2.4.2
compat.linux.oss_version: 198144
# netstat -m
322/704/131072 mbufs in use (current/peak/max):
322 mbufs allocated to data
320/444/32768 mbuf clusters in use (current/peak/max)
1064 Kbytes allocated to network (1% of mb_map in use)
0 requests for memory denied
0 requests for memory delayed
0 calls to protocol drain routines
# ulimit -a
core file size (blocks, -c) unlimited
data seg size (kbytes, -d) 524288
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 14781
pipe size (512 bytes, -p) 1
stack size (kbytes, -s) 65536
cpu time (seconds, -t) unlimited
max user processes (-u) 7390
virtual memory (kbytes, -v) unlimited