Hi! I wonder why APFloat::convertToDouble asserts if it is not an APFloat::IEEEdouble while the name "convertToDouble" suggests that it converts when it is not a double. -Jochen
On Jul 9, 2010, at 7:59 AMPDT, Jochen Wilhelmy wrote:> Hi! > > I wonder why APFloat::convertToDouble asserts if it is not an > APFloat::IEEEdouble while the name "convertToDouble" suggests that it > converts when it is not a double.The conversion is to (host) double, as the name implies. Among APFloat types, that is only implemented for APFloat::IEEEdouble.
>> >> I wonder why APFloat::convertToDouble asserts if it is not an >> APFloat::IEEEdouble while the name "convertToDouble" suggests that it >> converts when it is not a double. > > The conversion is to (host) double, as the name implies. Among > APFloat types, that is only implemented for APFloat::IEEEdouble. >yes, it's to host double ("convert this APFloat to double"), therefore I hoped that it works for any APFloat type (otherwise I would suggest a name such as getIfIEEEdouble() ). Is there a reason against it or would it be accepted if it would work for any type?