Anton Yakovlev
2021-Mar-02 08:09 UTC
[PATCH v6 9/9] ALSA: virtio: introduce device suspend/resume support
On 02.03.2021 07:48, Takashi Iwai wrote:> On Tue, 02 Mar 2021 07:29:20 +0100, > Anton Yakovlev wrote: >> >> On 28.02.2021 13:05, Takashi Iwai wrote: >>> On Sat, 27 Feb 2021 09:59:56 +0100, >>> Anton Yakovlev wrote: >>>> >> >> [snip] >> >>>> --- a/sound/virtio/virtio_pcm.c >>>> +++ b/sound/virtio/virtio_pcm.c >>>> @@ -109,6 +109,7 @@ static int virtsnd_pcm_build_hw(struct virtio_pcm_substream *vss, >>>> SNDRV_PCM_INFO_BATCH | >>>> SNDRV_PCM_INFO_BLOCK_TRANSFER | >>>> SNDRV_PCM_INFO_INTERLEAVED | >>>> + SNDRV_PCM_INFO_RESUME | >>>> SNDRV_PCM_INFO_PAUSE; >>> >>> Actually you don't need to set SNDRV_PCM_INFO_RESUME. >>> This flag means that the driver supports the full resume procedure, >>> which isn't often the case; with this, the driver is supposed to >>> resume the stream exactly from the suspended position. >>> >>> Most drivers don't set this but implement only the suspend-stop >>> action. Then the application (or the sound backend) will re-setup the >>> stream and restart accordingly. >> >> I tried to resume driver without SNDRV_PCM_INFO_RESUME, and alsa-lib >> called only ops->prepare(). It makes sense for a typical hw, but we have >> "clean" unconfigured device on resume. And we must set hw parameters as >> a first step. It means, that code should be more or less the same. And >> maybe it's better to set SNDRV_PCM_INFO_RESUME, since it allows us to >> resume substream in any situation (regardless of application behavior). >> I can refactor code to only send requests from trigger(RESUME) path and >> not to call ops itself. It should make code more straitforward. What do >> you say? > > How about calling hw_params(NULL) conditionally in the prepare?Then the question is that condition. When ops->prepare() is called, the substream is in SUSPENDED state or not? If not then we need to track this in some additional field (and it will make logic a little bit clumsy, since that field is needed to be carefully handled in other places).> Doing the full stack work in the trigger callback is bad from the API > design POV; in general the trigger callback is supposed to be as short > as possible.Yeah, but usually original subsystem design does not take into account para-virtualized devices, which usually have it's own slightly different reality. And we need to introduce some tricks.> > Takashi >-- Anton Yakovlev Senior Software Engineer OpenSynergy GmbH Rotherstr. 20, 10245 Berlin