Christophe Leroy
2022-Mar-05 09:51 UTC
[Nouveau] [PATCH] drm/nouveau/bios: Rename prom_init() and friends functions
Le 05/03/2022 ? 08:38, Christophe Leroy a ?crit?:> > > Le 04/03/2022 ? 21:24, Lyude Paul a ?crit?: >> This mostly looks good to me. Just one question (and one comment down >> below >> that needs addressing). Is this with ppc32? (I ask because ppc64le >> doesn't >> seem to hit this compilation error). > > That's with PPC64, see > http://kisskb.ellerman.id.au/kisskb/branch/chleroy/head/252ba609bea83234d2e35841c19ae84c67b43ec7/ > > > But that's not (yet) with the mainline tree. That's work I'm doing to > cleanup our asm/asm-protoypes.h header. > > Since commit 4efca4ed05cb ("kbuild: modversions for EXPORT_SYMBOL() for > asm") that file is dedicated to prototypes of functions defined in > assembly. Therefore I'm trying to dispatch C functions prototypes in > other headers. I wanted to move prom_init() prototype into asm/prom.h > and then I hit the problem. > > In the beginning I was thinking about just changing the name of the > function in powerpc, but as I see that M68K, MIPS and SPARC also have a > prom_init() function, I thought it would be better to change the name in > shadowrom.c to avoid any future conflict like the one I got while > reworking the headers. > > >>> @@ -57,8 +57,8 @@ prom_init(struct nvkm_bios *bios, const char *name) >>> ??const struct nvbios_source >>> ??nvbios_rom = { >>> ?????????.name = "PROM", >>> -???????.init = prom_init, >>> -???????.fini = prom_fini, >>> -???????.read = prom_read, >>> +???????.init = nvbios_rom_init, >>> +???????.fini = nvbios_rom_fini, >>> +???????.read = nvbios_rom_read, >> >> Seeing as the source name is prom, I think using the naming convention >> nvbios_prom_* would be better then nvbios_rom_*. >> > > Yes I wasn't sure about the best naming as the file name is shadowrom.c > and not shadowprom.c. > > I will send v2 using nvbios_prom_* as a name.While preparing v2 I remembered that in fact, I called the functions nvbios_rom_* because the name of the nvbios_source struct is nvbios_rom, so for me it made sense to use the name of the struct as a prefix for the functions. So I'm OK to change it to nvbios_prom_* but it looks less logical to me. Please confirm you still prefer nvbios_prom as prefix to the function names. Christophe
Christophe Leroy
2022-Mar-18 09:55 UTC
[Nouveau] [PATCH] drm/nouveau/bios: Rename prom_init() and friends functions
Hi Paul, Le 05/03/2022 ? 10:51, Christophe Leroy a ?crit?:> > > Le 05/03/2022 ? 08:38, Christophe Leroy a ?crit?: >> >> >> Le 04/03/2022 ? 21:24, Lyude Paul a ?crit?: >>> This mostly looks good to me. Just one question (and one comment down >>> below >>> that needs addressing). Is this with ppc32? (I ask because ppc64le >>> doesn't >>> seem to hit this compilation error). >> >> That's with PPC64, see >> http://kisskb.ellerman.id.au/kisskb/branch/chleroy/head/252ba609bea83234d2e35841c19ae84c67b43ec7/ >> >> >> But that's not (yet) with the mainline tree. That's work I'm doing to >> cleanup our asm/asm-protoypes.h header. >> >> Since commit 4efca4ed05cb ("kbuild: modversions for EXPORT_SYMBOL() >> for asm") that file is dedicated to prototypes of functions defined in >> assembly. Therefore I'm trying to dispatch C functions prototypes in >> other headers. I wanted to move prom_init() prototype into asm/prom.h >> and then I hit the problem. >> >> In the beginning I was thinking about just changing the name of the >> function in powerpc, but as I see that M68K, MIPS and SPARC also have >> a prom_init() function, I thought it would be better to change the >> name in shadowrom.c to avoid any future conflict like the one I got >> while reworking the headers. >> >> >>>> @@ -57,8 +57,8 @@ prom_init(struct nvkm_bios *bios, const char *name) >>>> ??const struct nvbios_source >>>> ??nvbios_rom = { >>>> ?????????.name = "PROM", >>>> -???????.init = prom_init, >>>> -???????.fini = prom_fini, >>>> -???????.read = prom_read, >>>> +???????.init = nvbios_rom_init, >>>> +???????.fini = nvbios_rom_fini, >>>> +???????.read = nvbios_rom_read, >>> >>> Seeing as the source name is prom, I think using the naming convention >>> nvbios_prom_* would be better then nvbios_rom_*. >>> >> >> Yes I wasn't sure about the best naming as the file name is >> shadowrom.c and not shadowprom.c. >> >> I will send v2 using nvbios_prom_* as a name. > > While preparing v2 I remembered that in fact, I called the functions > nvbios_rom_* because the name of the nvbios_source struct is nvbios_rom, > so for me it made sense to use the name of the struct as a prefix for > the functions. > > So I'm OK to change it to nvbios_prom_* but it looks less logical to me. > > Please confirm you still prefer nvbios_prom as prefix to the function > names. >Are you still expecting a v2 for this patch ? As the name of the structure is nvbios_rom, do you really prefer the functions to be called nvbios_prom_* as you mentionned in your comment ? In that case, do you also expect the structure name to be changed to nvbios_prom ? Thanks Christophe
Lyude Paul
2022-Mar-18 18:10 UTC
[Nouveau] [PATCH] drm/nouveau/bios: Rename prom_init() and friends functions
Whoops, sorry! I was unsure of the preference in name we should go with so I poked Ben on the side to ask them, but I can see they haven't yet responded. I'll poke thme again and see if I can get a response. On Fri, 2022-03-18 at 10:55 +0100, Christophe Leroy wrote:> Hi Paul, > > Le 05/03/2022 ? 10:51, Christophe Leroy a ?crit?: > > > > > > Le 05/03/2022 ? 08:38, Christophe Leroy a ?crit?: > > > > > > > > > Le 04/03/2022 ? 21:24, Lyude Paul a ?crit?: > > > > This mostly looks good to me. Just one question (and one comment down > > > > below > > > > that needs addressing). Is this with ppc32? (I ask because ppc64le > > > > doesn't > > > > seem to hit this compilation error). > > > > > > That's with PPC64, see > > > http://kisskb.ellerman.id.au/kisskb/branch/chleroy/head/252ba609bea83234d2e35841c19ae84c67b43ec7/ > > > ? > > > > > > > > > But that's not (yet) with the mainline tree. That's work I'm doing to > > > cleanup our asm/asm-protoypes.h header. > > > > > > Since commit 4efca4ed05cb ("kbuild: modversions for EXPORT_SYMBOL() > > > for asm") that file is dedicated to prototypes of functions defined in > > > assembly. Therefore I'm trying to dispatch C functions prototypes in > > > other headers. I wanted to move prom_init() prototype into asm/prom.h > > > and then I hit the problem. > > > > > > In the beginning I was thinking about just changing the name of the > > > function in powerpc, but as I see that M68K, MIPS and SPARC also have > > > a prom_init() function, I thought it would be better to change the > > > name in shadowrom.c to avoid any future conflict like the one I got > > > while reworking the headers. > > > > > > > > > > > @@ -57,8 +57,8 @@ prom_init(struct nvkm_bios *bios, const char > > > > > *name) > > > > > ??const struct nvbios_source > > > > > ??nvbios_rom = { > > > > > ?????????.name = "PROM", > > > > > -???????.init = prom_init, > > > > > -???????.fini = prom_fini, > > > > > -???????.read = prom_read, > > > > > +???????.init = nvbios_rom_init, > > > > > +???????.fini = nvbios_rom_fini, > > > > > +???????.read = nvbios_rom_read, > > > > > > > > Seeing as the source name is prom, I think using the naming convention > > > > nvbios_prom_* would be better then nvbios_rom_*. > > > > > > > > > > Yes I wasn't sure about the best naming as the file name is > > > shadowrom.c and not shadowprom.c. > > > > > > I will send v2 using nvbios_prom_* as a name. > > > > While preparing v2 I remembered that in fact, I called the functions > > nvbios_rom_* because the name of the nvbios_source struct is nvbios_rom, > > so for me it made sense to use the name of the struct as a prefix for > > the functions. > > > > So I'm OK to change it to nvbios_prom_* but it looks less logical to me. > > > > Please confirm you still prefer nvbios_prom as prefix to the function > > names. > > > > Are you still expecting a v2 for this patch ? > > As the name of the structure is nvbios_rom, do you really prefer the > functions to be called nvbios_prom_* as you mentionned in your comment ? > > In that case, do you also expect the structure name to be changed to > nvbios_prom ? > > Thanks > Christophe >-- Cheers, Lyude Paul (she/her) Software Engineer at Red Hat