Displaying 20 results from an estimated 1000 matches similar to: "[PATCH] paravirt: fix error handling in paravirt_disable_iospace"
2007 Jun 05
1
[PATCH] paravirt: helper to disable all IO space
In a virtual environment, device drivers such as legacy IDE will waste
quite a lot of time probing for their devices which will never appear.
This helper function allows a paravirt implementation to lay claim to
the whole iomem and ioport space, thereby disabling all device drivers
trying to claim IO resources.
Signed-off-by: Jeremy Fitzhardinge <jeremy@xensource.com>
Cc: Rusty Russell
2017 May 19
0
[PATCH 02/10] paravirt: remove unused function paravirt_disable_iospace()
paravirt_disable_iospace() isn't used anywhere. Remove it.
Signed-off-by: Juergen Gross <jgross at suse.com>
---
arch/x86/include/asm/paravirt_types.h | 2 --
arch/x86/kernel/paravirt.c | 19 -------------------
2 files changed, 21 deletions(-)
diff --git a/arch/x86/include/asm/paravirt_types.h b/arch/x86/include/asm/paravirt_types.h
index 7465d6fe336f..7a5de42cb465 100644
2007 Dec 20
6
[PATCH 0/15] adjust pvops to accomodate its x86_64 variant
Hi folks,
With this series, the bulk of the work of pvops64 is done.
Here, I integrate most of the paravirt.c and paravirt.h files, making
them applicable to both architectures.
CONFIG_PARAVIRT is _not_ present yet. Basically, this code is missing page
table integration (patches currently being worked on by Jeremy).
Enjoy
2007 Dec 20
6
[PATCH 0/15] adjust pvops to accomodate its x86_64 variant
Hi folks,
With this series, the bulk of the work of pvops64 is done.
Here, I integrate most of the paravirt.c and paravirt.h files, making
them applicable to both architectures.
CONFIG_PARAVIRT is _not_ present yet. Basically, this code is missing page
table integration (patches currently being worked on by Jeremy).
Enjoy
2019 Jun 13
0
[PATCH 06/22] mm: factor out a devm_request_free_mem_region helper
Keep the physical address allocation that hmm_add_device does with the
rest of the resource code, and allow future reuse of it without the hmm
wrapper.
Signed-off-by: Christoph Hellwig <hch at lst.de>
---
include/linux/ioport.h | 2 ++
kernel/resource.c | 39 +++++++++++++++++++++++++++++++++++++++
mm/hmm.c | 33 ++++-----------------------------
3 files changed, 45
2019 Jun 17
0
[PATCH 06/25] mm: factor out a devm_request_free_mem_region helper
Keep the physical address allocation that hmm_add_device does with the
rest of the resource code, and allow future reuse of it without the hmm
wrapper.
Signed-off-by: Christoph Hellwig <hch at lst.de>
Reviewed-by: Jason Gunthorpe <jgg at mellanox.com>
Reviewed-by: John Hubbard <jhubbard at nvidia.com>
---
include/linux/ioport.h | 2 ++
kernel/resource.c | 39
2019 Jun 15
1
[PATCH 06/22] mm: factor out a devm_request_free_mem_region helper
On 6/13/19 2:43 AM, Christoph Hellwig wrote:
> Keep the physical address allocation that hmm_add_device does with the
> rest of the resource code, and allow future reuse of it without the hmm
> wrapper.
>
> Signed-off-by: Christoph Hellwig <hch at lst.de>
> ---
> include/linux/ioport.h | 2 ++
> kernel/resource.c | 39 +++++++++++++++++++++++++++++++++++++++
2013 May 16
1
[RFC PATCH v2, part3 07/11] PCI, xen-pcifront: use new PCI interfaces to simplify implementation
Use new PCI interfaces to simplify xen-pcifront implementation:
1) Use pci_create_root_bus() instead of pci_scan_bus_parented()
because pci_scan_bus_parented() is marked as __deprecated.This
also gets rid of a duplicated call of pci_bus_start_devices().
2) Use pci_stop_root_bus() and pci_remove_root_bus() instead of
open-coded private implementation.
3) Use pci_set_host_bridge_release()
2013 May 16
1
[RFC PATCH v2, part3 07/11] PCI, xen-pcifront: use new PCI interfaces to simplify implementation
Use new PCI interfaces to simplify xen-pcifront implementation:
1) Use pci_create_root_bus() instead of pci_scan_bus_parented()
because pci_scan_bus_parented() is marked as __deprecated.This
also gets rid of a duplicated call of pci_bus_start_devices().
2) Use pci_stop_root_bus() and pci_remove_root_bus() instead of
open-coded private implementation.
3) Use pci_set_host_bridge_release()
2013 May 16
1
[RFC PATCH v2, part3 07/11] PCI, xen-pcifront: use new PCI interfaces to simplify implementation
Use new PCI interfaces to simplify xen-pcifront implementation:
1) Use pci_create_root_bus() instead of pci_scan_bus_parented()
because pci_scan_bus_parented() is marked as __deprecated.This
also gets rid of a duplicated call of pci_bus_start_devices().
2) Use pci_stop_root_bus() and pci_remove_root_bus() instead of
open-coded private implementation.
3) Use pci_set_host_bridge_release()
2015 Jun 16
0
[PATCH] virtio-pci: alloc only resources actually used.
On Tue, Jun 16, 2015 at 03:57:52PM +0200, Gerd Hoffmann wrote:
> Move resource allocation from common code to legacy and modern code.
> Only request resources actually used, i.e. bar0 in legacy mode and
> the regions specified by capabilities in modern mode.
>
> Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
> ---
> drivers/virtio/virtio_pci_common.c | 7 -----
2015 Jun 18
0
[PATCH v2] virtio-pci: alloc only resources actually used.
On Thu, Jun 18, 2015 at 11:27:34AM +0200, Gerd Hoffmann wrote:
> Move resource allocation from common code to legacy and modern code.
> Only request resources actually used, i.e. bar0 in legacy mode and
> the regions specified by capabilities in modern mode.
>
> Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
> ---
> drivers/virtio/virtio_pci_common.c | 7 ----
2015 Jun 16
2
[PATCH] virtio-pci: alloc only resources actually used.
Move resource allocation from common code to legacy and modern code.
Only request resources actually used, i.e. bar0 in legacy mode and
the regions specified by capabilities in modern mode.
Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
---
drivers/virtio/virtio_pci_common.c | 7 -----
drivers/virtio/virtio_pci_common.h | 5 ++++
drivers/virtio/virtio_pci_legacy.c | 13 +++++++++-
2015 Jun 16
2
[PATCH] virtio-pci: alloc only resources actually used.
Move resource allocation from common code to legacy and modern code.
Only request resources actually used, i.e. bar0 in legacy mode and
the regions specified by capabilities in modern mode.
Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
---
drivers/virtio/virtio_pci_common.c | 7 -----
drivers/virtio/virtio_pci_common.h | 5 ++++
drivers/virtio/virtio_pci_legacy.c | 13 +++++++++-
2015 Jun 18
2
[PATCH v2] virtio-pci: alloc only resources actually used.
Move resource allocation from common code to legacy and modern code.
Only request resources actually used, i.e. bar0 in legacy mode and
the regions specified by capabilities in modern mode.
Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
---
drivers/virtio/virtio_pci_common.c | 7 ----
drivers/virtio/virtio_pci_common.h | 5 +++
drivers/virtio/virtio_pci_legacy.c | 13 +++++++-
2015 Jun 18
2
[PATCH v2] virtio-pci: alloc only resources actually used.
Move resource allocation from common code to legacy and modern code.
Only request resources actually used, i.e. bar0 in legacy mode and
the regions specified by capabilities in modern mode.
Signed-off-by: Gerd Hoffmann <kraxel at redhat.com>
---
drivers/virtio/virtio_pci_common.c | 7 ----
drivers/virtio/virtio_pci_common.h | 5 +++
drivers/virtio/virtio_pci_legacy.c | 13 +++++++-
2020 Sep 15
0
[PATCH v2 1/7] kernel/resource: make release_mem_region_adjustable() never fail
On 15.09.20 11:06, Wei Yang wrote:
> On Tue, Sep 15, 2020 at 09:35:30AM +0200, David Hildenbrand wrote:
>>
>>>> static int __ref try_remove_memory(int nid, u64 start, u64 size)
>>>> {
>>>> int rc = 0;
>>>> @@ -1777,7 +1757,7 @@ static int __ref try_remove_memory(int nid, u64 start, u64 size)
>>>> memblock_remove(start, size);
2020 Sep 15
0
[PATCH v2 1/7] kernel/resource: make release_mem_region_adjustable() never fail
>> static int __ref try_remove_memory(int nid, u64 start, u64 size)
>> {
>> int rc = 0;
>> @@ -1777,7 +1757,7 @@ static int __ref try_remove_memory(int nid, u64 start, u64 size)
>> memblock_remove(start, size);
>> }
>>
>> - __release_memory_resource(start, size);
>> + release_mem_region_adjustable(&iomem_resource, start, size);
>>
2017 Oct 04
1
[PATCH 02/13] x86/paravirt: Fix output constraint macro names
Some of the paravirt '*_CLOBBERS' macros refer to output constraints
instead of clobbers, which makes the code extra confusing. Rename the
output constraint related macros to '*_OUTPUTS'.
Signed-off-by: Josh Poimboeuf <jpoimboe at redhat.com>
---
arch/x86/include/asm/paravirt_types.h | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
diff
2018 Dec 17
0
[PATCH v3 04/12] Revert "x86/paravirt: Work around GCC inlining bugs when compiling paravirt ops"
This reverts commit 494b5168f2de009eb80f198f668da374295098dd.
The in-kernel workarounds will be replaced with GCC's new
"asm inline" syntax.
Signed-off-by: Masahiro Yamada <yamada.masahiro at socionext.com>
---
arch/x86/include/asm/paravirt_types.h | 56 ++++++++++++++++++-----------------
arch/x86/kernel/macros.S | 1 -
2 files changed, 29 insertions(+), 28