Displaying 20 results from an estimated 90 matches similar to: "[PATCH common] mlutils: Simple wrapper around sysconf (_SC_NPROCESSORS_ONLN)."
2017 Oct 11
1
[PATCH] common/mlutils: fix f_type comparisons
statfs::f_type is usually a signed type, so cast it to unsigned to check
its value against magic values of filesystems.
---
common/mlutils/unix_utils-c.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/common/mlutils/unix_utils-c.c b/common/mlutils/unix_utils-c.c
index f8c4f8abe..2afdc9e5f 100644
--- a/common/mlutils/unix_utils-c.c
+++ b/common/mlutils/unix_utils-c.c
@@
2020 Sep 18
1
Re: [PATCH v2v] v2v: Set the number of vCPUs to same as host number of pCPUs.
On Friday, 18 September 2020 11:44:04 CEST Richard W.M. Jones wrote:
> let g = open_guestfs ~identifier:"v2v" () in
> g#set_memsize (g#get_memsize () * 14 / 5);
> + (* Setting the number of vCPUs allows parallel mkinitrd. *)
> + g#set_smp (Sysconf.nr_processors_online ());
IMHO this is not a good idea, for few reasons:
a) it unconditionally uses all the available
2017 Oct 04
2
[PATCH v3 0/2] builder: Choose better weights in the planner.
v2 -> v3:
- Drop gnulib fallback.
2020 Sep 18
0
[PATCH v2v] v2v: Set the number of vCPUs to same as host number of pCPUs.
This helps mkinitrd which runs pigz (parallel gzip).
Thanks Jean-Louis Dupond for suggesting this change.
---
common | 2 +-
v2v/v2v.ml | 2 ++
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/common b/common
index c840f2e39..ea5278bba 160000
--- a/common
+++ b/common
@@ -1 +1 @@
-Subproject commit c840f2e39d0bb637a98b224c89f6df011e1d4414
+Subproject commit
2013 May 13
0
[klibc:sysconf] Framework and trivial implementation of sysconf(3)
Commit-ID: 0e725b1ec953aafa7cec75a22436319e945f93e1
Gitweb: http://git.kernel.org/?p=libs/klibc/klibc.git;a=commit;h=0e725b1ec953aafa7cec75a22436319e945f93e1
Author: H. Peter Anvin <hpa at linux.intel.com>
AuthorDate: Mon, 13 May 2013 11:36:38 -0700
Committer: H. Peter Anvin <hpa at linux.intel.com>
CommitDate: Mon, 13 May 2013 11:36:38 -0700
[klibc] Framework and trivial
2017 Jun 16
1
Re: [PATCH v6 10/41] mllib, v2v: Split out OCaml utils bindings ‘common/mlutils’.
On Thursday, 15 June 2017 19:06:00 CEST Richard W.M. Jones wrote:
> Create a module ‘C_utils’ containing functions like ‘drive_name’ and
> ‘shell_unquote’ which come from the C utilities.
>
> The new directory ‘common/mlutils’ also contains the ‘Unix_utils’
> wrappers around POSIX functions missing from the OCaml stdlib.
> ---
I fear we are spreading the code among too many
2017 Jul 11
2
[PATCH 1/2] builder: fix paths to mlstdutils & mlutils
Followup/fix of commit 61d4891ef48df171a27873efe90aab51a9b711ef.
---
builder/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builder/Makefile.am b/builder/Makefile.am
index 09ae4ae..e64c899 100644
--- a/builder/Makefile.am
+++ b/builder/Makefile.am
@@ -311,7 +311,7 @@ depend: .depend
.depend: $(wildcard $(abs_srcdir)/*.mli) $(wildcard $(abs_srcdir)/*.ml)
rm -f
2020 Jul 08
1
Request to merge branch sysconf into master
The sysconf branch only contains a single commit:
[klibc] Framework and trivial implementation of sysconf(3)
The sysconf() function is required by libkcapi. I use libkcapi
in my klibc based initramfs in order to decrypt the file system
key for my rootfs.
Can somebody merge this commit into master? After that I would
like to send further patches required by libkcapi.
regards
Christian
2020 Jul 25
0
[klibc:master] tests: Add a trivial test for sysconf()
Commit-ID: 8db4a47db4c72203a9196a2c5d096664de29f8ce
Gitweb: http://git.kernel.org/?p=libs/klibc/klibc.git;a=commit;h=8db4a47db4c72203a9196a2c5d096664de29f8ce
Author: Ben Hutchings <ben at decadent.org.uk>
AuthorDate: Sat, 25 Jul 2020 22:46:16 +0100
Committer: Ben Hutchings <ben at decadent.org.uk>
CommitDate: Sat, 25 Jul 2020 22:46:16 +0100
[klibc] tests: Add a trivial test
2020 Jul 25
0
[klibc:master] tests: Add a trivial test for sysconf()
Commit-ID: eae5223098f32ba5cbb83631cec2579f764ee6ff
Gitweb: http://git.kernel.org/?p=libs/klibc/klibc.git;a=commit;h=eae5223098f32ba5cbb83631cec2579f764ee6ff
Author: Ben Hutchings <ben at decadent.org.uk>
AuthorDate: Sat, 25 Jul 2020 22:48:23 +0100
Committer: Ben Hutchings <ben at decadent.org.uk>
CommitDate: Sat, 25 Jul 2020 22:48:23 +0100
[klibc] tests: Add a trivial test
2020 Jul 25
0
[klibc:master] tests: Add a trivial test for sysconf()
Commit-ID: 3df6e74ab78fc63aa025d07fb849ec9508cbf1c2
Gitweb: http://git.kernel.org/?p=libs/klibc/klibc.git;a=commit;h=3df6e74ab78fc63aa025d07fb849ec9508cbf1c2
Author: Ben Hutchings <ben at decadent.org.uk>
AuthorDate: Sat, 25 Jul 2020 22:46:16 +0100
Committer: Ben Hutchings <ben at decadent.org.uk>
CommitDate: Sat, 25 Jul 2020 22:51:45 +0100
[klibc] tests: Add a trivial test
2017 Sep 17
0
sysconf and _SC_LEVEL1_DCACHE_LINESIZE returns 0?
Hi Everyone,
I'm working on GCC112, which is POWER System S822 (Power8) machine
running CentOS 7 machine (https://gcc.gnu.org/wiki/CompileFarm):
$ cat /etc/centos-release
CentOS Linux release 7.3.1611 (AltArch)
I'm trying to determine L1 data cache size. When the following code
runs it returns 0. The man pages state -1 is an error, so I think its
claiming to succeed.
2024 Sep 11
2
[Bug 3735] New: The ngroups variable may be set to a negative value when calling sysconf(_SC_NGROUPS_MAX)
https://bugzilla.mindrot.org/show_bug.cgi?id=3735
Bug ID: 3735
Summary: The ngroups variable may be set to a negative value
when calling sysconf(_SC_NGROUPS_MAX)
Product: Portable OpenSSH
Version: 9.8p1
Hardware: Other
OS: All
Status: NEW
Severity: normal
Priority: P5
2000 Feb 03
2
use sysconf instead of NGROUPS_MAX
Currently samba (2.0.6) relies on the NGROUPS_MAX define. This makes
the number of allowed simultaneous (per-user) secondary groups a
compile-time decision.
$ find . -name \*.c | xargs grep NGROUPS
./source/lib/system.c: if (setlen > NGROUPS_MAX) {
./source/lib/replace.c: gid_t grouplst[NGROUPS_MAX];
./source/lib/replace.c: while (i < NGROUPS_MAX &&
2020 Sep 18
4
[PATCH v2v] v2v: Set the number of vCPUs to same as host number of pCPUs.
So it didn't make any noticable difference in my test. I wonder if
the test guest I'm using (Fedora 32 using dracut) doesn't use parallel
compression?
However I don't think it can cause a problem and it seems obvious that
it could benefit some cases.
Rich.
2017 Jun 15
0
[PATCH v6 10/41] mllib, v2v: Split out OCaml utils bindings ‘common/mlutils’.
Create a module ‘C_utils’ containing functions like ‘drive_name’ and
‘shell_unquote’ which come from the C utilities.
The new directory ‘common/mlutils’ also contains the ‘Unix_utils’
wrappers around POSIX functions missing from the OCaml stdlib.
---
.gitignore | 3 +
Makefile.am | 24 ++---
builder/Makefile.am
2017 Oct 03
4
[PATCH v2 0/2] builder: Choose better weights in the planner.
v1 -> v2:
- Removed the f_type field from StatVFS.statvfs structure.
- New function StatVFS.filesystem_is_remote, written in C.
[Thinking about it, this should probably be called
?is_network_filesystem?, but I can change that before
pushing].
- Use statvfs instead of fstatvfs, and statfs instead of fstatfs.
- Rejigged the comments in builder/builder.ml to make them simpler
2017 Jul 21
2
[PATCH] common/mlutils: Remove bogus suffix parameter from Mkdtemp.temp_dir.
The C function mkdtemp(3) requires that the string ends with 6 'X'
characters, so appending a non-empty suffix causes the function to
raise EINVAL.
Luckily we only ever called this function with the last parameter "".
---
builder/builder.ml | 2 +-
builder/sigchecker.ml | 2 +-
common/mlutils/unix_utils.ml | 4 ++--
2008 Feb 10
0
Possible VCPU hotplug bug
I am working on a project that uses OpenMP along with Xen''s VCPU
hotplug feature. The OpenMP libraries are used for writing
multi-threaded applications, and they have a function named
omp_get_num_procs() that is used to determine the number of processors
available on the system. I noticed that when using the xm vcpu-set
command in Xen to change the number of vcpus assigned to a domU
2015 Mar 05
1
Re: [PATCH 1/2] New API: btrfs-image
On Tue, Mar 03, 2015 at 03:48:02AM -0500, Chen Hanxiao wrote:
> Signed-off-by: Chen Hanxiao <chenhanxiao@cn.fujitsu.com>
> + if (compresslevel >= 0) {
> + snprintf (compresslevel_s, sizeof compresslevel_s, "%d", compresslevel);
> + ADD_ARG (argv, i, "-c");
> + ADD_ARG (argv, i, compresslevel_s);
> + }
Because compresslevel is an optional