similar to: [PATCH v3 0/5] sysprep: Remove various backup files.

Displaying 20 results from an estimated 5000 matches similar to: "[PATCH v3 0/5] sysprep: Remove various backup files."

2016 Dec 14
4
[PATCH 0/4] sysprep: Remove various backup files.
https://bugzilla.redhat.com/show_bug.cgi?id=1401320 This series contains two new operations. The second -- and least controversial -- is "passwd-backups" which removes files such as /etc/passwd-, /etc/shadow- and so on. The first one ("backup-files") searches the whole guest filesystem for any regular file which looks like an editor backup file, such as "*~" and
2016 Dec 14
6
[PATCH v2 0/4] sysprep: Remove various backup files.
In v2: - The backup-files operation now operates on a conservative whitelist of filesystems, so it won't touch anything in /usr. Consequently it also runs much more quickly, about 4 seconds on the barebones virt-builder fedora-25 image. - Call Gc.compact () in visit_tests. - Added documentation to fnmatch.mli.
2017 Sep 26
5
[PATCH 0/5] Miscellaneous refactoring of common/utils, create common/mltools
Miscellaneous refactoring, but the main one is to rename mllib/ as common/mltools/ Rich.
2017 Feb 22
4
[PATCH 0/3] v2v: vCenter: Remove proxy environment variables
Fix for: https://bugzilla.redhat.com/show_bug.cgi?id=1354507 Main explanation is in patch #3. Rich.
2017 Oct 04
11
[PATCH 0/9] build: Require OCaml >= 4.02.
Per my previous email: https://www.redhat.com/archives/libguestfs/2017-September/msg00203.html I'd like to talk about requiring a more modern version of the OCaml compiler. These commits show some of the code changes which would be possible with OCaml >= 3.12 [which it turns out we already require by accident] and also with OCaml >= 4.02. The latter is my favoured option. Rich.
2017 Mar 29
1
[PATCH] mllib: cast integer pointers to intptr_t as intermediate step
This make sure there is no mismatch between the size of the integer value that Int64_val returns, and the size of the guestfs_h pointer. This should fix the warning on 32bit environments (and thus build, when --enable-werror is enabled). --- mllib/visit-c.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/mllib/visit-c.c b/mllib/visit-c.c index b46dd33..b1c1216 100644 ---
2017 Jun 19
16
[PATCH v7 00/13] Refactor utilities
This is just the utilities part of the patch series from: https://www.redhat.com/archives/libguestfs/2017-June/msg00103.html I believe this addresses everything raised in comments on that patch series. Rich.
2017 Jun 09
12
[PATCH 00/12] Refactor utility functions.
This turned out to be rather more involved than I thought. We have lots of utility functions, spread all over the repository, with not a lot of structure. This moves many of them under common/ and structures them so there are clear dependencies. This doesn't complete the job by any means. Other items I had on my to-do list for this change were: - Split up mllib/common_utils into: -
2015 Jul 08
7
[PATCH 0/6] RFC: basic subscription-manager support in virt-customize
Hi, this series introduces a basic support for registering/attaching/unregistering RHEL guests using subscription-manager, so it is possible to do for example: $ cat <<EOF > sm.conf [general] username=user password=pass [attach-0] pool=ID EOF $ virt-customize -a rhel-guest.qcow2 \ --sm-config sm.conf --sm-register --sm-attach 0 \ --install pkg1 --install pkg2
2017 Jul 18
3
[PATCH] v2v: bootloaders: Handle no Bootloader::Tools default section (RHBZ#1472208).
In SUSE guests, handle the case where Bootloader::Tools::GetDefaultSection () returns undef. Previously this would return an empty string and cause a bogus error in subsequent code: virt-v2v: error: libguestfs error: statns: statns_stub: path must start with a / character --- v2v/linux_bootloaders.ml | 17 ++++++++++++++--- 1 file changed, 14 insertions(+), 3 deletions(-) diff --git
2014 Apr 30
3
[PATCH 2/2] Fix handling of passwords in URLs
So far, passwords in URLs (eg http://user:password@host..) have been handled as part of the username, and thus passing add-drive path username:username:password ... instead of add-drive path username:username secret:password ... Fix the parsing of URLs to handle passwords as separate elements, properly passing it as "secret" parameter for add-drive, and properly readd it when
2017 Jun 12
32
[PATCH v5 00/32] Refactor utilities, implement some APIs in OCaml.
This is a combination of: https://www.redhat.com/archives/libguestfs/2017-June/msg00046.html [PATCH 00/12] Refactor utility functions. plus: https://www.redhat.com/archives/libguestfs/2017-June/msg00023.html [PATCH v3 00/19] Allow APIs to be implemented in OCaml. with the second patches rebased on top of the utility refactoring, and some other adjustments and extensions. This passes
2017 Oct 02
3
[PATCH 0/2] builder: Choose better weights in the planner.
It started out as "this'll be just a simple fix ..." and turned into something a bit over-engineered in the end. Here it is anyway. Rich.
2017 Oct 04
2
[PATCH v3 0/2] builder: Choose better weights in the planner.
v2 -> v3: - Drop gnulib fallback.
2017 Sep 20
4
[PATCH 0/4] Replace some uses of the Str module with PCRE.
Str is a pretty ugly regexp module. Let's try to replace it with PCRE. This series of commits goes some small way towards that eventual goal. - - - I wonder if there was a deep reason why we had this? let unix2dos s = String.concat "\r\n" (Str.split_delim (Str.regexp_string "\n") s) I replaced it with what I think should be (nearly) equivalent: let unix2dos s =
2017 Jul 18
4
[PATCH v2 0/2] v2v: Add slow tests of opensuse 13.1, 13.2 and 42.1
v1 was: https://www.redhat.com/archives/libguestfs/2017-July/msg00154.html There is no change in the first patch, but I added a second patch adding slow tests of opensuse guests (which pass, but require the first patch). Rich.
2017 Oct 03
4
[PATCH v2 0/2] builder: Choose better weights in the planner.
v1 -> v2: - Removed the f_type field from StatVFS.statvfs structure. - New function StatVFS.filesystem_is_remote, written in C. [Thinking about it, this should probably be called ?is_network_filesystem?, but I can change that before pushing]. - Use statvfs instead of fstatvfs, and statfs instead of fstatfs. - Rejigged the comments in builder/builder.ml to make them simpler
2015 Feb 02
1
RFC: Handle query strings for http and https (RHBZ#1092583)
Parse the query string from URLs, and pass it as new add_drive optarg; use it when building the file= URL for qemu. Accept query string only for http and https protocols, for now. --- Possibly it looks like an ad-hoc solution for http(s), although I'm not sure how it could possibly be generalized somehow (maybe "extra params" which would be the query string for http(s)?).
2017 Jun 27
3
[PATCH] libvirt: disallow non-local connections (RHBZ#1347830)
If the connection is not local, paths of disks will refer to the remote host, which were mistakenly handled as local paths (in the best case failing to open a non-existing disk, and in the worst case opening a different disk!). In case the disks are remote resources like ssh or ceph, nothing guarantees that the hostname can be reached from the local machine, or even that it is actually the same on
2017 Jul 07
4
[PATCH v6 0/3] gobject: Remove gtk-doc (RHBZ#1465665).
Hopefully this time ...