similar to: [PATCH] gpu: Consistently use octal not symbolic permissions

Displaying 20 results from an estimated 4000 matches similar to: "[PATCH] gpu: Consistently use octal not symbolic permissions"

2018 May 25
0
[PATCH] gpu: Consistently use octal not symbolic permissions
Well I think we rejected that multiple times now. At least I find the symbolic permissions easier to read and I absolutely don't see any reason why we should only use one form. Christian. Am 24.05.2018 um 22:22 schrieb Joe Perches: > There is currently a mixture of octal and symbolic permissions uses > in files in drivers/gpu/drm and one file in drivers/gpu. > > There are ~270
2017 May 02
1
[PATCH v5 5/5] nouveau_hwmon: Change permissions to numeric
On 26/04/17 19:46, Oscar Salvador wrote: > This patch replaces the symbolic permissions with the numeric ones, > and adds me to the authors too. > > Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> > --- > drivers/gpu/drm/nouveau/nouveau_hwmon.c | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) > > diff --git
2020 Feb 18
1
[PATCH] drm/nouveau: remove checks for return value of debugfs functions
As there is no need to check for the return value of debugfs_create_file and drm_debugfs_create_files, remove unnecessary checks and error handling in nouveau_drm_debugfs_init. Signed-off-by: Wambui Karuga <wambui.karugax at gmail.com> --- drivers/gpu/drm/nouveau/nouveau_debugfs.c | 20 ++++++++------------ 1 file changed, 8 insertions(+), 12 deletions(-) diff --git
2020 Feb 09
3
[PATCH] nouveau: no need to check return value of debugfs_create functions
When calling debugfs functions, there is no need to ever check the return value. The function can work or not, but the code logic should never do something different based on this. Cc: Ben Skeggs <bskeggs at redhat.com> Cc: David Airlie <airlied at linux.ie> Cc: Daniel Vetter <daniel at ffwll.ch> Cc: dri-devel at lists.freedesktop.org Cc: nouveau at lists.freedesktop.org
2016 Apr 11
0
[PATCH] nouveau: Switch perms from macros to octal notations, module params readable to everyone
From: poma <pomidorabelisima at gmail.com> Switch from "silly" S_* macros to "definitely more readable" octal "way" permissions, moreover to not "so restrictive" module parameters permissions. Suggested-by: Ilia Mirkin <imirkin at alum.mit.edu> Fixes: poma <pomidorabelisima at gmail.com> Tested-by: poma <pomidorabelisima at
2017 Apr 11
2
[PATCH 1/1] nouveau_hwmon: migrate to hwmon_device_register_with_info
Hi, this patch replaces the old hwmon_device_register with the new hwmon_device_register_with_info. I've tested it on my laptop with a GeForceGT 425M and it doesn't break anything. --- linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c.orig 2017-04-11 18:27:15.477623009 +0200 +++ linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c 2017-04-11 18:45:41.918688215 +0200 @@ -1,5 +1,6 @@ /* - *
2018 May 23
3
[PATCH] block drivers/block: Use octal not symbolic permissions
Convert the S_<FOO> symbolic permissions to their octal equivalents as using octal and not symbolic permissions is preferred by many as more readable. see: https://lkml.org/lkml/2016/8/2/1945 Done with automated conversion via: $ ./scripts/checkpatch.pl -f --types=SYMBOLIC_PERMS --fix-inplace <files...> Miscellanea: o Wrapped modified multi-line calls to a single line where
2018 May 23
3
[PATCH] block drivers/block: Use octal not symbolic permissions
Convert the S_<FOO> symbolic permissions to their octal equivalents as using octal and not symbolic permissions is preferred by many as more readable. see: https://lkml.org/lkml/2016/8/2/1945 Done with automated conversion via: $ ./scripts/checkpatch.pl -f --types=SYMBOLIC_PERMS --fix-inplace <files...> Miscellanea: o Wrapped modified multi-line calls to a single line where
2013 Sep 06
2
[PATCH RESEND v3 3/7] Intel MIC Host Driver, card OS state management.
Again, very minor fixups for later (I can even do them...) > +static DEVICE_ATTR(state, S_IRUGO|S_IWUSR, mic_show_state, mic_store_state); DEVICE_ATTR_RW() please. Same for the other attributes you create in this patch. thanks, greg k-h
2013 Sep 06
2
[PATCH RESEND v3 3/7] Intel MIC Host Driver, card OS state management.
Again, very minor fixups for later (I can even do them...) > +static DEVICE_ATTR(state, S_IRUGO|S_IWUSR, mic_show_state, mic_store_state); DEVICE_ATTR_RW() please. Same for the other attributes you create in this patch. thanks, greg k-h
2014 Mar 19
5
[PATCH] virtio-blk: make the queue depth configurable
Joe Perches <joe at perches.com> writes: > On Sun, 2014-03-16 at 22:00 -0700, Joe Perches wrote: >> On Mon, 2014-03-17 at 14:25 +1030, Rusty Russell wrote: >> >> > Erk, our tests are insufficient. Testbuilding an allmodconfig with this >> > now: >> >> Good idea. >> >> > diff --git a/include/linux/moduleparam.h
2014 Mar 19
5
[PATCH] virtio-blk: make the queue depth configurable
Joe Perches <joe at perches.com> writes: > On Sun, 2014-03-16 at 22:00 -0700, Joe Perches wrote: >> On Mon, 2014-03-17 at 14:25 +1030, Rusty Russell wrote: >> >> > Erk, our tests are insufficient. Testbuilding an allmodconfig with this >> > now: >> >> Good idea. >> >> > diff --git a/include/linux/moduleparam.h
2020 Feb 27
0
[PATCH 09/21] drm/nouveau: remove checks for return value of debugfs functions
Since 987d65d01356 (drm: debugfs: make drm_debugfs_create_files() never fail), there is no need to ever check for the the return value of debugfs_create_file() and drm_debugfs_create_files(). Therefore, remove unnecessary checks and error handling in nouveau_drm_debugfs_init. These changes also enable nouveau_drm_debugfs_init() to be declared as void. Signed-off-by: Wambui Karuga
2020 Mar 10
0
[PATCH v2 11/17] drm/nouveau: make nouveau_drm_debugfs_init() return 0
Since 987d65d01356 (drm: debugfs: make drm_debugfs_create_files() never fail), there is no need to ever check for the the return value of debugfs_create_file() and drm_debugfs_create_files(). Therefore, remove unnecessary checks and error handling in nouveau_drm_debugfs_init() and have the function return 0 directly. v2: have nouveau_drm_debugfs_init() return 0 instead of void so as not to
2017 Apr 13
0
[PATCH 4/4] nouveau_hwmon: migrate to hwmon_device_register_with_info
This patch replaces symbolic permissions with the numeric ones and adds me to the authors too. --- linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c.orig 2017-04-13 10:18:37.471129756 +0200 +++ linux/drivers/gpu/drm/nouveau/nouveau_hwmon.c 2017-04-13 10:19:58.182025638 +0200 @@ -1,5 +1,6 @@ /* - * Copyright 2010 Red Hat Inc. + * Copyright 2010 Red Hat Inc. (Ben Skeggs) + * Copyright 2017 Oscar
2017 Apr 26
0
[PATCH v5 5/5] nouveau_hwmon: Change permissions to numeric
This patch replaces the symbolic permissions with the numeric ones, and adds me to the authors too. Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_hwmon.c b/drivers/gpu/drm/nouveau/nouveau_hwmon.c index
2017 Apr 26
0
[PATCH v5 3/5] nouveau_hwmon: Remove old code, add .write/.read operations
This patch removes old code related to the old api and transforms the functions for the new api. It also adds the .write and .read operations. Signed-off-by: Oscar Salvador <osalvador.vilardaga at gmail.com> --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 722 +++++++++++--------------------- 1 file changed, 249 insertions(+), 473 deletions(-) diff --git
2017 Apr 26
9
[PATCH v5 0/5] replace hwmon_device_register for hwmon_device_register_with_info
This v5 drops a check for attr_set. Versions: v1 -> v2: * Keep temp attrs as read only v2 -> v3: * Code fix-ups: struct and string as const and add return within switch due to fallthrough * Add Signed-off-by to all commits v3 -> v4: * Rever const to struct attribute. Kbuild complains. v4 -> v5: * Drops a check for attr_set in
2017 Apr 12
0
[PATCH 1/1] nouveau_hwmon: migrate to hwmon_device_register_with_info
Sorry for that. I'll split the patch and I'll come again ;) El dia 11/04/2017 22:12, "Karol Herbst" <karolherbst at gmail.com> va escriure: thanks for the work, but could you please split that patch? It looks like you are doing several things at once and it isn't really easy to review like this. And it isn't bisectable. If there are clean ups here, please do it
2017 May 08
5
[PATCH v6 0/5] replace hwmon_device_register for hwmon_device_register_with_info
This v6 fixes some comments pointed out by Martin Peres. Versions: v1 -> v2: * Keep temp attrs as read only v2 -> v3: * Code fix-ups: struct and string as const and add return within switch due to fallthrough * Add Signed-off-by to all commits v3 -> v4: * Rever const to struct attribute. Kbuild complains. v4 -> v5: * Drops a check for