Volker Diels-Grabsch
2021-Jun-08 10:36 UTC
Reminder: Add ssh_config equivalents of -N, -n and -f
Dear Damien, Thanks for your response! Damien Miller wrote:> I'm not sure about the naming of NoShell, because it's really about not > starting any kind of remote session.I didn't really care about how to name this. All I did was noting that the flag is stored in a C variable "no_shell", which I just translated to camel case. So I assume that we should rename that C variable as well?> So the options are to rename the option to something like NoSession, > find a way to reuse the existing RemoteCommand option (though that is > IMO a little ugly) or perhaps introduce a new "SessionType" option > that can subsume functionality of both the -N (SessionType=none) and > -s (SessionType=subsystem) flags. > > What do you think?I also don't think that reusing RemoteCommand is a good idea. This would add unnecessary entaglement of mostly-unrelated options, and as such increase the risk of accidentally introducing bugs. I'd prefer to rename NoShell to NoSession, and perhaps to do the same for the internal variable names for consistency. Then, we would have a one-to-one match of command line and configuration file, which is IMHO the least surprise for users already familiar with "-N" and "-s". However, I'm not opposed to introduce "SessionType=none/subsystem", in case you like me to implement it that way. How should we proceed from here? Which variant should I implement? Best regards, Volker -- Volker Diels-Grabsch ----<<<((()))>>>----
Morgan, Iain (ARC-TN)[InuTeq, LLC]
2021-Jun-08 18:10 UTC
[EXTERNAL] Re: Reminder: Add ssh_config equivalents of -N, -n and -f
Hi, Of the choices enumerated by Damien, SessionType seems the most useful. I assume there should be a third value to designate a normal interactive session. Although, I'm dubious about the ovbious choice of "interactive." -- Iain Morgan ?On 6/8/21, 03:37, "openssh-unix-dev on behalf of Volker Diels-Grabsch" <openssh-unix-dev-bounces+iain.morgan=nasa.gov at mindrot.org on behalf of v at njh.eu> wrote: Dear Damien, Thanks for your response! Damien Miller wrote: > I'm not sure about the naming of NoShell, because it's really about not > starting any kind of remote session. I didn't really care about how to name this. All I did was noting that the flag is stored in a C variable "no_shell", which I just translated to camel case. So I assume that we should rename that C variable as well? > So the options are to rename the option to something like NoSession, > find a way to reuse the existing RemoteCommand option (though that is > IMO a little ugly) or perhaps introduce a new "SessionType" option > that can subsume functionality of both the -N (SessionType=none) and > -s (SessionType=subsystem) flags. > > What do you think? I also don't think that reusing RemoteCommand is a good idea. This would add unnecessary entaglement of mostly-unrelated options, and as such increase the risk of accidentally introducing bugs. I'd prefer to rename NoShell to NoSession, and perhaps to do the same for the internal variable names for consistency. Then, we would have a one-to-one match of command line and configuration file, which is IMHO the least surprise for users already familiar with "-N" and "-s". However, I'm not opposed to introduce "SessionType=none/subsystem", in case you like me to implement it that way. How should we proceed from here? Which variant should I implement? Best regards, Volker -- Volker Diels-Grabsch ----<<<((()))>>>---- _______________________________________________ openssh-unix-dev mailing list openssh-unix-dev at mindrot.org https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.mindrot.org%2Fmailman%2Flistinfo%2Fopenssh-unix-dev&data=04%7C01%7Ciain.morgan%40nasa.gov%7C633c1ca29ea34f159b1a08d92a695976%7C7005d45845be48ae8140d43da96dd17b%7C0%7C0%7C637587454241342637%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SDC3Kxmia3vcxRyfpm%2FTAbH3vCj4EdctwTyUb5oR6FU%3D&reserved=0
On Tue, 8 Jun 2021, Volker Diels-Grabsch wrote:> I'd prefer to rename NoShell to NoSession, and perhaps to do the same > for the internal variable names for consistency. Then, we would have > a one-to-one match of command line and configuration file, which is > IMHO the least surprise for users already familiar with "-N" and "-s". > > However, I'm not opposed to introduce "SessionType=none/subsystem", in > case you like me to implement it that way. > > How should we proceed from here? Which variant should I implement?I think SessionType=none/subsystem/default is the way to go. I'll have some time to look at it next week, but if you want to implement it then please don't let me stop you :) Thanks again for your patience. -d